summaryrefslogtreecommitdiff
path: root/app-emacs/yasnippet
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/yasnippet')
-rw-r--r--app-emacs/yasnippet/Manifest2
-rw-r--r--app-emacs/yasnippet/yasnippet-0.14.1_p20240406.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/yasnippet/Manifest b/app-emacs/yasnippet/Manifest
index c330ddb9e50e..f1a6b3b6e1fe 100644
--- a/app-emacs/yasnippet/Manifest
+++ b/app-emacs/yasnippet/Manifest
@@ -1,4 +1,6 @@
AUX 50yasnippet-gentoo-0.13.0.el 221 BLAKE2B 51f86d04a825b5e1cb60019bddac2b0e2d91d735ffafdae497c87413eb0ad88efd969575edfe139ba250d2e2115f1c5a242de61f54031b684f35437e6e868989 SHA512 ace64b43229ee327add5d6ac056b86f7468ffb79569ca55d3692c93fd4b9e847d83fa731c8e54ad2aced5d64ed73c9cfa1fc6d6f9a883356dbb6a39142d9a2fb
DIST yasnippet-0.14.0.tar.gz 581053 BLAKE2B efae02939d0174724803819fb9a47a414acad3b1d58da91d4f35c42c02282db9773f4f3caa020d01c2d87de741d3c60b39e1406b6ff7b3e5310ed4efc477d635 SHA512 c7f704187b3c700f8ea9e0205941d7a32602b6994307007cb83aa984ccf7e7e37be9589277a56c294703eab82ee4b1dffae7040f2e175e7d56cda5ef3c70eb39
+DIST yasnippet-0.14.1_p20240406.tar.gz 581059 BLAKE2B 44ae910a495ba7c507ef1316cc358116ed984af69314316ae7a78c41ae6f84c4406e0959848f229c9546240c98d01e99d1accb5e9b6b8aeed3a7191f9ab918d4 SHA512 6aca3aef7b4a4b6cc03a7926fa6203758b1124c92e906d3eb355f2ee8bee95e4ca2a8a8929b4e7837f8999b23e66dc68429bb4117dde90d92f21ddd76cbb1c70
EBUILD yasnippet-0.14.0.ebuild 1065 BLAKE2B 542aa300855f07be78dad0461ca985ed231c5f0272cefd17a1d9c9580b0ef3453155ef34049825f93218f1d290138cdefea111b26d33cb169feb127dc9be83b0 SHA512 e2674da97207992c74fee437b1027c2ff88c3fb707547c57b25f44939a15ff688751cf788fbfe796c215e36f80affa14bf9b26d7163d2ad0edd52bef558527df
+EBUILD yasnippet-0.14.1_p20240406.ebuild 1299 BLAKE2B 63db6214bd65fd54b6f1dd8c704bccf989ec5a9dcb42da71e3b9399f4551af890cacd3b7c7b7e9b12b7e291b456b16fcd8dc00c93d103c10f493003e72c7d6b9 SHA512 8f3c1e986af242f9318c645d1cd9bd15db50de4a4f784d9827cbb5b0ab05bf22830e41a982aab589f2756615f3a81a42a16d508a43d5a1daf73ca09636a24061
MISC metadata.xml 520 BLAKE2B 2c5dbc7b7bedf1a900acbb8a48b07787857479210f3ea504a30119ee2669039ad00ddbdd09712dcb21cd99ed7db62ba4f81d901effe5442148ea40e0cb2c9220 SHA512 0c738db961c5deaffbae27974d89fccae4002c1209316b0ad1f9140a4959de9911edacab324b02f3bbec70db235da3454f08d43a7d8a4c13d955a99aff27487b
diff --git a/app-emacs/yasnippet/yasnippet-0.14.1_p20240406.ebuild b/app-emacs/yasnippet/yasnippet-0.14.1_p20240406.ebuild
new file mode 100644
index 000000000000..ab2e2918e115
--- /dev/null
+++ b/app-emacs/yasnippet/yasnippet-0.14.1_p20240406.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Yet another snippet extension for Emacs"
+HOMEPAGE="https://joaotavora.github.io/yasnippet/
+ https://github.com/joaotavora/yasnippet/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joaotavora/${PN}.git"
+else
+ [[ "${PV}" == *p20240406 ]] && COMMIT="e23a80177a9c434174ed8a5955c296d7828a1060"
+
+ SRC_URI="https://github.com/joaotavora/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+
+ KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+SITEFILE="50${PN}-gentoo-0.13.0.el"
+
+elisp-enable-tests ert -L . -l yasnippet-tests
+
+src_install() {
+ elisp-install "${PN}" yasnippet.{el,elc} yasnippet-debug.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc CONTRIBUTING.md NEWS README.mdown
+ use doc && dodoc -r doc/*
+
+ local DOC_CONTENTS="Add the following to your ~/.emacs to use YASnippet:
+ \n\t(require 'yasnippet)
+ \n\t(yas-global-mode 1)
+ \n\nYASnippet no longer bundles snippets directly. Install the package
+ app-emacs/yasnippet-snippets for a collection of snippets."
+ readme.gentoo_create_doc
+}