summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin76960 -> 76959 bytes
-rw-r--r--app-emacs/emacs-daemon/Manifest2
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.23.ebuild51
3 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index ea1cb48a8c51..f45303b6f797 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/emacs-daemon/Manifest b/app-emacs/emacs-daemon/Manifest
index 22b768c97163..e0330005ad17 100644
--- a/app-emacs/emacs-daemon/Manifest
+++ b/app-emacs/emacs-daemon/Manifest
@@ -1,3 +1,5 @@
DIST emacs-daemon-0.22.tar.xz 5276 BLAKE2B a866b14951df94e1d382253dcb7045beb800c9dd754f7eed40eadecde43fd583bb2bc20ad9ccc9f87174b06aadbb26f7875deaf36d9bb5325f98ffa58fded8c7 SHA512 f013cd00d3a24ca348bf718dd20dec7bea89107c0a27c921d6b58595b611991830604fc658d57681708218fbee1dae6dd0b277a2a9da67639e3553e0fd133094
+DIST emacs-daemon-0.23.tar.xz 4876 BLAKE2B 95fd9fc2b038dd60d4fc889674f4f1c3e5c0f8894a0161a0ea626835e91d500766e7fb50f8efafd70b0a45129626968147009c218b55ca0df6c6da50b8cb99dc SHA512 90f4b5b22df17106173de6116f45d902613b60b4b837293ea5f7843ad4967f68f9920cb301ef1edc50c6c831941be487b456ac8c1bc41ae41a55c6e1ea135343
EBUILD emacs-daemon-0.22-r1.ebuild 1606 BLAKE2B 1d521e7d5177e864bcc365e7fe978ea4380b68380d69e542c7b1801723657dee2780b2e2441d6b5831712b550e0763f36878b913cc0acb3e42a5d1f5d9df994c SHA512 e3f1fac107add3017b522e446f22c81910cb67e05bb4008d061d371a7e7336942fef33fbd426e13ac0dda94701f1cb4fb16cf860d57c36121948dd3414c62ef0
+EBUILD emacs-daemon-0.23.ebuild 1655 BLAKE2B 0f04993f482708927f2e06779a588af9ff97935d2de7a1c04f8493d9c072cdbd8672f06fa864ba44b0d7ccd4c4f9366ff666b7478259d03d8ff7bd42343badf4 SHA512 3be88552eea164aa17a0dee904c10d8d26ea9faae31692b8dfb9efeabccd74aedeae3fd075e03596d5d26be9eb46fbc3845878f828310b709cb67e71f3a3175c
MISC metadata.xml 362 BLAKE2B 59c9e3025bdd347e4812d6485bda2b731a1b0adf2eec16aefdd6b0d3379a949cd99c637febfcab0c6314c457eafe0727a986196e4499aa29dbd297a6a0458d66 SHA512 5882c9372b62c44189426a1ea3ac975e29b70fc5b5d30a3f024edced82d9406e118e9acee91b1353c76eb65f19008e4bb1475f859509c933be48c03aa701394b
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.23.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.23.ebuild
new file mode 100644
index 000000000000..eeb3e9f0786e
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.23.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon has_gtk line
+ has_daemon=$(${EMACS} ${EMACSFLAGS} --eval "(princ (fboundp 'daemonp))")
+ has_gtk=$(${EMACS} ${EMACSFLAGS} --eval "(princ (featurep 'gtk))")
+
+ if [[ ${has_daemon} != t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs version does not support running as a daemon which
+ is required for ${CATEGORY}/${PN}.
+ Use "eselect emacs" to select an Emacs version >= 23.
+ EOF
+ elif [[ ${has_gtk} == t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs is compiled with GTK+. There is a long-standing bug
+ in GTK+ that prevents Emacs from recovering from X disconnects:
+ <https://gitlab.gnome.org/GNOME/gtk/-/issues/221> and
+ <https://gitlab.gnome.org/GNOME/gtk/-/issues/2315>.
+ If you run Emacs as a daemon, then it is strongly recommended that you
+ compile it with the Lucid or the Motif toolkit instead, i.e. with
+ USE="athena Xaw3d -gtk -motif" or USE="motif -gtk -athena -Xaw3d".
+ EOF
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs
+ newconfd emacs.conf emacs
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh
+ elisp-site-file-install "${SITEFILE}"
+ dodoc README ChangeLog
+}