summaryrefslogtreecommitdiff
path: root/app-emulation/dynamips/dynamips-0.2.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/dynamips/dynamips-0.2.12.ebuild')
-rw-r--r--app-emulation/dynamips/dynamips-0.2.12.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emulation/dynamips/dynamips-0.2.12.ebuild b/app-emulation/dynamips/dynamips-0.2.12.ebuild
new file mode 100644
index 000000000000..134ef537bf0d
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.12.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="http://www.gns3.net/dynamips/"
+SRC_URI="mirror://sourceforge/project/gns-3/Dynamips/${PV}/${P}-source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+
+ # enable verbose build
+ sed -i \
+ -e 's/@$(CC)/$(CC)/g' \
+ stable/Makefile || die 'sed on stable/Makefile failed'
+ # respect compiler
+ tc-export CC
+
+ epatch_user
+}
+
+src_compile() {
+ if use amd64 || use x86; then
+ emake DYNAMIPS_ARCH="${ARCH}"
+ else
+ emake DYNAMIS_ARCH="nojit"
+ fi
+}
+
+src_install () {
+ newbin dynamips.stable dynamips
+ newbin nvram_export.stable nvram_export
+ doman man/*
+ dodoc README README.hypervisor TODO
+}