summaryrefslogtreecommitdiff
path: root/app-emulation/fs-uae/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/fs-uae/files')
-rw-r--r--app-emulation/fs-uae/files/fs-uae-3.1.35-ar.patch25
-rw-r--r--app-emulation/fs-uae/files/fs-uae-3.1.35-deepbind.patch43
2 files changed, 68 insertions, 0 deletions
diff --git a/app-emulation/fs-uae/files/fs-uae-3.1.35-ar.patch b/app-emulation/fs-uae/files/fs-uae-3.1.35-ar.patch
new file mode 100644
index 000000000000..9075723da74c
--- /dev/null
+++ b/app-emulation/fs-uae/files/fs-uae-3.1.35-ar.patch
@@ -0,0 +1,25 @@
+From 4e6295094978817ba02e16ac5404ac9c9e287c82 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sun, 17 Oct 2021 09:54:24 +0100
+Subject: [PATCH] Have configure respect the AR variable instead of setting it
+ to "ar"
+
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index bb2c69de..6e41d68e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -66,6 +66,7 @@ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
++AM_PROG_AR
+ AM_PROG_CC_C_O
+ # AC_PATH_TOOL(OBJCOPY, objcopy)
+ AC_PATH_PROG([MSGFMT], [msgfmt], [not found])
+--
+2.32.0
+
diff --git a/app-emulation/fs-uae/files/fs-uae-3.1.35-deepbind.patch b/app-emulation/fs-uae/files/fs-uae-3.1.35-deepbind.patch
new file mode 100644
index 000000000000..0a60301772f1
--- /dev/null
+++ b/app-emulation/fs-uae/files/fs-uae-3.1.35-deepbind.patch
@@ -0,0 +1,43 @@
+From c5b02df4598c5fbe7a034b67ee06c506abeb3828 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Mon, 18 Oct 2021 10:22:09 +0100
+Subject: [PATCH] Don't assume RTLD_DEEPBIND is always present on Linux
+
+It's not supported by musl.
+---
+ configure.ac | 5 +++++
+ src/dlopen.cpp | 2 +-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6e41d68e..2cac2dac 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -655,6 +655,11 @@ AC_CHECK_FUNCS([gettimeofday])
+ AC_CHECK_DECLS([CLOCK_MONOTONIC], [], [], [#include <time.h>])
+
+
++# RTLD_DEEPBIND is not supported by all C libraries.
++
++AC_CHECK_DECLS([RTLD_DEEPBIND], [], [], [#include <dlfcn.h>])
++
++
+ # Check for POSIX support.
+
+ AS_CASE([$host_os],
+diff --git a/src/dlopen.cpp b/src/dlopen.cpp
+index f79c401b..14edbc02 100644
+--- a/src/dlopen.cpp
++++ b/src/dlopen.cpp
+@@ -22,7 +22,7 @@ UAE_DLHANDLE uae_dlopen(const TCHAR *path)
+ }
+ #ifdef _WIN32
+ result = LoadLibrary(path);
+-#elif defined(LINUX)
++#elif HAVE_DECL_RTLD_DEEPBIND == 1
+ result = dlopen(path, RTLD_NOW | RTLD_DEEPBIND);
+ #else
+ result = dlopen(path, RTLD_NOW);
+--
+2.32.0
+