summaryrefslogtreecommitdiff
path: root/app-emulation/fuse-utils
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/fuse-utils')
-rw-r--r--app-emulation/fuse-utils/Manifest3
-rw-r--r--app-emulation/fuse-utils/files/remove-local-prefix.patch22
-rw-r--r--app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild13
3 files changed, 36 insertions, 2 deletions
diff --git a/app-emulation/fuse-utils/Manifest b/app-emulation/fuse-utils/Manifest
index ea39ed8b1590..787d472fad5f 100644
--- a/app-emulation/fuse-utils/Manifest
+++ b/app-emulation/fuse-utils/Manifest
@@ -1,3 +1,4 @@
+AUX remove-local-prefix.patch 841 BLAKE2B c29e10ed335d431c0cbd88a26028c03599c32d9ded001fa1f61f805589bd1c52352b52ac8f99c147af315ee91d65681d1c0aa355567108f92767f36fa6f6dee1 SHA512 c15ac87af402e06296d76459a13b5817be7393839ca1566c6f0eefaa3055f7f3f0dc7589f762d9caa0e0bd356790bbb1aca5c3ee6166155577bf3520f25ed125
DIST fuse-utils-1.4.3.tar.gz 501006 BLAKE2B 0637fe05b71416e89eb61e3618ff45bd71250201924fb3741a4c5b9898d09b30acecba9957baeaa864c2c9cfe1bcb9cb38a2af83368bc5729221cec36a1eda47 SHA512 13404d1be81a2de9262cd79cce9dd8dc3f17238fdbb75da8a724b76b0976c03f34da9978af36b808103fedcf3f5d5da4bb10f251c5510127d59ca8de5607b99e
-EBUILD fuse-utils-1.4.3.ebuild 795 BLAKE2B 13acba2469ffdad7e89436efd518aeb2767565506217971e2df1d5e12e06733e88d63c05f5aa4f3c64385787271a1e8e31cbc4b04ad04d71bd205d73cf3a3387 SHA512 b1392dcee95f6ad700c1acba03934eefde74e6aa9d005738468c9fd5b069c3c29ed1614fee54483d13231588456d43cce9854eb4e0eeec713eca08800a22999f
+EBUILD fuse-utils-1.4.3.ebuild 906 BLAKE2B 5d0e2325e3256617e87a1a147626cfa74b3e77638dc0218a45952e469cdf046ca76e97f61667f41bd63965795fbdc69ec3adf0689f6f7464795608dca71415bd SHA512 0d64435c04cfeb91259f0969aeb99b2d84128861772f9c2baa344bb4956b18c9d14e0d8e7251c9491b7a0fabd6fb82d8e590ef210263c6e5050b2dd11724b347
MISC metadata.xml 602 BLAKE2B 434afcae9b53d97c7c5ed9f4c5dca410f6f5b39716b751a5a04458a9420652b8403dbbe1d24f73ebaebea34f45f7d6138ade181388772a5294419c86fd033d78 SHA512 42657b608b54739aa7d1cc56c7172bac79b00d327594334e13c471fa52c5d2e026aedff351758b5a292bc89b19d340ee04727ed5a551b9f6c944b096762dae17
diff --git a/app-emulation/fuse-utils/files/remove-local-prefix.patch b/app-emulation/fuse-utils/files/remove-local-prefix.patch
new file mode 100644
index 000000000000..41daba71cdd9
--- /dev/null
+++ b/app-emulation/fuse-utils/files/remove-local-prefix.patch
@@ -0,0 +1,22 @@
+diff -Naur fuse-utils-1.4.3/configure.ac fuse-utils-1.4.3-patched/configure.ac
+--- fuse-utils-1.4.3/configure.ac 2018-07-01 02:09:55.000000000 +0200
++++ fuse-utils-1.4.3-patched/configure.ac 2020-07-28 17:02:05.287721692 +0200
+@@ -92,18 +92,6 @@
+ )
+ fi
+
+-dnl Allow the user to say that various libraries are in one place
+-AC_ARG_WITH(local-prefix,
+-[ --with-local-prefix=PFX local libraries installed in PFX (optional)],
+-CPPFLAGS="$CPPFLAGS -I$withval/include";
+-CXXFLAGS="$CXXFLAGS -I$withval/include";
+-LDFLAGS="$LDFLAGS -L$withval/lib",
+-if test "$prefix" != "NONE"; then
+- CPPFLAGS="$CPPFLAGS -I$prefix/include";
+- CXXFLAGS="$CXXFLAGS -I$prefix/include";
+- LDFLAGS="$LDFLAGS -L$prefix/lib"
+-fi)
+-
+ dnl Check if libjpeg is available and supports jpeg_write_scanlines
+ AC_MSG_CHECKING(whether to use libjpeg)
+ AC_ARG_WITH(libjpeg,
diff --git a/app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild b/app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild
index fb8728c0836b..8e44998a4a6a 100644
--- a/app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild
+++ b/app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit autotools
+
DESCRIPTION="Utils for the Free Unix Spectrum Emulator by Philip Kendall"
HOMEPAGE="http://fuse-emulator.sourceforge.net"
SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
@@ -20,6 +22,15 @@ RDEPEND=">=app-emulation/libspectrum-1.4.4[gcrypt?,zlib?]
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/remove-local-prefix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myconf=(
$(use_with audiofile)