summaryrefslogtreecommitdiff
path: root/app-emulation/libvirt/libvirt-7.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libvirt/libvirt-7.7.0.ebuild')
-rw-r--r--app-emulation/libvirt/libvirt-7.7.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/app-emulation/libvirt/libvirt-7.7.0.ebuild b/app-emulation/libvirt/libvirt-7.7.0.ebuild
index 34cffee86294..9ced809f24aa 100644
--- a/app-emulation/libvirt/libvirt-7.7.0.ebuild
+++ b/app-emulation/libvirt/libvirt-7.7.0.ebuild
@@ -16,7 +16,7 @@ if [[ ${PV} = *9999* ]]; then
else
SRC_URI="https://libvirt.org/sources/${P}.tar.xz
verify-sig? ( https://libvirt.org/sources/${P}.tar.xz.asc )"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS="amd64 arm64 ~ppc64 x86"
SLOT="0/${PV}"
fi
@@ -217,6 +217,11 @@ src_prepare() {
default
python_fix_shebang .
+ # Skip fragile tests which relies on pristine environment
+ # (Breaks because of sandbox environment variables)
+ # bug #802876
+ sed -i -e "/commandtest/d" tests/meson.build || die
+
# Tweak the init script:
cp "${FILESDIR}/libvirtd.init-r19" "${S}/libvirtd.init" || die
sed -e "s/USE_FLAG_FIREWALLD/$(usex firewalld 'need firewalld' '')/" \
@@ -281,7 +286,11 @@ src_configure() {
src_test() {
export VIR_TEST_DEBUG=1
- meson_src_test
+ # Don't run the syntax check tests, they're fragile and not relevant
+ # to us downstream anyway.
+ # We also crank up the timeout (as Fedora does) just to preempt failures
+ # on slower arches.
+ meson_src_test --no-suite syntax-check --timeout-multiplier 10
}
src_install() {