summaryrefslogtreecommitdiff
path: root/app-emulation/ruffle/ruffle-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/ruffle/ruffle-9999.ebuild')
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index 2b341d6744e5..2e43a88f8190 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -3,18 +3,16 @@
EAPI=8
-# python is needed by xcb-0.8.2 until update to >=0.10
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE="xml(+)"
-inherit cargo desktop flag-o-matic git-r3 python-any-r1 xdg
+inherit cargo desktop flag-o-matic git-r3 xdg
DESCRIPTION="Flash Player emulator written in Rust"
HOMEPAGE="https://ruffle.rs/"
EGIT_REPO_URI="https://github.com/ruffle-rs/ruffle.git"
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB curl"
+LICENSE="Apache-2.0 BSD BSD-2 Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB curl"
SLOT="0"
+# dlopen: libX* (see winit+x11-dl crates)
RDEPEND="
dev-libs/glib:2
dev-libs/openssl:=
@@ -23,18 +21,19 @@ RDEPEND="
media-libs/freetype
sys-libs/zlib:=
x11-libs/gtk+:3
- x11-libs/libxcb:="
-DEPEND="${RDEPEND}"
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXrender"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="
- ${PYTHON_DEPS}
virtual/jre:*
virtual/pkgconfig
>=virtual/rust-1.64"
-QA_FLAGS_IGNORED="
- usr/bin/${PN}
- usr/bin/${PN}_exporter
- usr/bin/${PN}_scanner"
+QA_FLAGS_IGNORED="usr/bin/${PN}.*"
src_unpack() {
git-r3_src_unpack