summaryrefslogtreecommitdiff
path: root/app-emulation/ruffle/ruffle-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/ruffle/ruffle-9999.ebuild')
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index fbc440002e65..a54f26933afa 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -78,9 +78,20 @@ src_configure() {
exporter
$(usev test tests)
)
+
cargo_src_configure ${workspaces[*]/#/--package=}
}
+src_test() {
+ local skip=(
+ # may need more investigation, strangely "pass" (xfail) when
+ # RUSTFLAGS is unset, skip for now (bug #915726)
+ --skip from_avmplus/as3/Types/Int/wraparound
+ )
+
+ cargo_src_test -- "${skip[@]}"
+}
+
src_install() {
dodoc README.md