summaryrefslogtreecommitdiff
path: root/app-emulation/runc/runc-1.0.0_rc10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/runc/runc-1.0.0_rc10.ebuild')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc10.ebuild18
1 files changed, 4 insertions, 14 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc10.ebuild b/app-emulation/runc/runc-1.0.0_rc10.ebuild
index 2338fa34630c..dc3d0ff8a266 100644
--- a/app-emulation/runc/runc-1.0.0_rc10.ebuild
+++ b/app-emulation/runc/runc-1.0.0_rc10.ebuild
@@ -14,14 +14,14 @@ else
# Change this when you update the ebuild
RUNC_COMMIT=dc9208a3303feef5b3839f4323d9beb36df0a9dd
SRC_URI="https://${EGO_PN}/archive/${RUNC_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc64"
inherit golang-build golang-vcs-snapshot
fi
DESCRIPTION="runc container cli tools"
HOMEPAGE="http://runc.io"
-LICENSE="Apache-2.0"
+LICENSE="Apache-2.0 BSD-2 BSD MIT"
SLOT="0"
IUSE="+ambient apparmor hardened +kmem +seccomp"
@@ -31,17 +31,6 @@ RDEPEND="
!app-emulation/docker-runc
"
-src_prepare() {
- pushd src/${EGO_PN}
- default
- sed -i -e "/^GIT_BRANCH/d"\
- -e "/^GIT_BRANCH_CLEAN/d"\
- -e "/^COMMIT_NO/d"\
- -e "s/COMMIT :=.*/COMMIT := ${RUNC_COMMIT}/"\
- Makefile || die
- popd || die
-}
-
src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
@@ -56,7 +45,8 @@ src_compile() {
$(usex kmem '' 'nokmem')
)
- GOPATH="${S}" emake BUILDTAGS="${options[*]}" -C src/${EGO_PN}
+ COMMIT=${RUNC_COMMIT} GOPATH="${S}" emake BUILDTAGS="${options[*]}" \
+ -C src/${EGO_PN}
}
src_install() {