summaryrefslogtreecommitdiff
path: root/app-emulation/spice/spice-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/spice/spice-9999.ebuild')
-rw-r--r--app-emulation/spice/spice-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/app-emulation/spice/spice-9999.ebuild b/app-emulation/spice/spice-9999.ebuild
index a7cd1fa64454..44eb9c360ee8 100644
--- a/app-emulation/spice/spice-9999.ebuild
+++ b/app-emulation/spice/spice-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit git-r3 meson python-any-r1 readme.gentoo-r1 xdg-utils
DESCRIPTION="SPICE server"
@@ -14,7 +14,9 @@ EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/spice.git"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="gstreamer libressl lz4 opus sasl smartcard static-libs"
+IUSE="gstreamer libressl lz4 opus sasl smartcard static-libs test"
+
+RESTRICT="!test? ( test )"
# the libspice-server only uses the headers of libcacard
RDEPEND="
@@ -35,7 +37,8 @@ RDEPEND="
)"
DEPEND="${RDEPEND}
~app-emulation/spice-protocol-9999
- smartcard? ( app-emulation/qemu[smartcard] )"
+ smartcard? ( app-emulation/qemu[smartcard] )
+ test? ( net-libs/glib-networking )"
BDEPEND="${PYTHON_DEPS}
virtual/pkgconfig
$(python_gen_any_dep '
@@ -73,6 +76,7 @@ src_configure() {
$(meson_use sasl)
$(meson_feature opus)
$(meson_feature smartcard)
+ $(meson_use test tests)
-Dmanual=false
-Dtests=false
)