summaryrefslogtreecommitdiff
path: root/app-emulation/wine-staging/wine-staging-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-9999.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 992a6503e0ea..f01c88936d1c 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -9,7 +9,7 @@ inherit autotools edo flag-o-matic multilib multilib-build optfeature
inherit prefix python-any-r1 toolchain-funcs wrapper
WINE_GECKO=2.47.4
-WINE_MONO=9.2.0
+WINE_MONO=9.3.0
WINE_P=wine-$(ver_cut 1-2)
if [[ ${PV} == *9999 ]]; then
@@ -36,11 +36,11 @@ LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
IUSE="
+X +abi_x86_32 +abi_x86_64 +alsa capi crossdev-mingw cups dos
- llvm-libunwind custom-cflags +fontconfig +gecko gphoto2 +gstreamer
- kerberos +mingw +mono netapi nls odbc opencl +opengl osmesa pcap
- perl pulseaudio samba scanner +sdl selinux smartcard +ssl +strip
- +truetype udev udisks +unwind usb v4l +vulkan wayland wow64
- +xcomposite xinerama
+ llvm-libunwind custom-cflags ffmpeg +fontconfig +gecko gphoto2
+ +gstreamer kerberos +mingw +mono netapi nls odbc opencl +opengl
+ osmesa pcap perl pulseaudio samba scanner +sdl selinux smartcard
+ +ssl +strip +truetype udev udisks +unwind usb v4l +vulkan wayland
+ wow64 +xcomposite xinerama
"
# bug #551124 for truetype
# TODO: wow64 can be done without mingw if using clang (needs bug #912237)
@@ -74,6 +74,7 @@ WINE_DLOPEN_DEPEND="
fontconfig? ( media-libs/fontconfig[${MULTILIB_USEDEP}] )
kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] )
netapi? ( net-fs/samba[${MULTILIB_USEDEP}] )
+ odbc? ( dev-db/unixODBC[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[haptic,joystick,${MULTILIB_USEDEP}] )
ssl? ( net-libs/gnutls:=[${MULTILIB_USEDEP}] )
truetype? ( media-libs/freetype[${MULTILIB_USEDEP}] )
@@ -89,13 +90,13 @@ WINE_COMMON_DEPEND="
)
alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
capi? ( net-libs/libcapi:=[${MULTILIB_USEDEP}] )
+ ffmpeg? ( media-video/ffmpeg:=[${MULTILIB_USEDEP}] )
gphoto2? ( media-libs/libgphoto2:=[${MULTILIB_USEDEP}] )
gstreamer? (
dev-libs/glib:2[${MULTILIB_USEDEP}]
media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}]
media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
)
- odbc? ( dev-db/unixODBC[${MULTILIB_USEDEP}] )
opencl? ( virtual/opencl[${MULTILIB_USEDEP}] )
pcap? ( net-libs/libpcap[${MULTILIB_USEDEP}] )
pulseaudio? ( media-libs/libpulse[${MULTILIB_USEDEP}] )
@@ -289,6 +290,7 @@ src_configure() {
$(use_with alsa)
$(use_with capi)
$(use_with cups)
+ $(use_with ffmpeg)
$(use_with fontconfig)
$(use_with gphoto2 gphoto)
$(use_with gstreamer)
@@ -297,7 +299,6 @@ src_configure() {
$(use_with mingw)
$(use_with netapi)
$(use_with nls gettext)
- $(use_with odbc)
$(use_with opencl)
$(use_with opengl)
$(use_with osmesa)
@@ -318,6 +319,7 @@ src_configure() {
$(use_with wayland)
$(use_with xcomposite)
$(use_with xinerama)
+ $(usev !odbc ac_cv_lib_soname_odbc=)
)
filter-lto # build failure