summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild')
-rw-r--r--app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild b/app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild
new file mode 100644
index 000000000000..c933884fa90f
--- /dev/null
+++ b/app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-hangul.git"
+fi
+
+DESCRIPTION="Korean Hangul input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-hangul"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="4"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ app-i18n/libhangul:=
+ virtual/libiconv
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}