summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-m17n/fcitx-m17n-5.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-m17n/fcitx-m17n-5.1.0.ebuild')
-rw-r--r--app-i18n/fcitx-m17n/fcitx-m17n-5.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/fcitx-m17n/fcitx-m17n-5.1.0.ebuild b/app-i18n/fcitx-m17n/fcitx-m17n-5.1.0.ebuild
new file mode 100644
index 000000000000..194032d2fb7e
--- /dev/null
+++ b/app-i18n/fcitx-m17n/fcitx-m17n-5.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-m17n"
+
+inherit cmake
+
+DESCRIPTION="m17n-provided input methods for Fcitx5"
+HOMEPAGE="https://github.com/fcitx/fcitx5-m17n"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# m17n-gui>=1.6.3
+RDEPEND="
+ >=app-i18n/fcitx-5.1.6:5
+ dev-db/m17n-db
+ dev-libs/libfmt
+ >=dev-libs/m17n-lib-1.6.3[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ kde-frameworks/extra-cmake-modules:0
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TEST=$(usex test)
+ )
+ cmake_src_configure
+}