summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-rime
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-rime')
-rw-r--r--app-i18n/fcitx-rime/Manifest4
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild30
-rw-r--r--app-i18n/fcitx-rime/metadata.xml13
3 files changed, 46 insertions, 1 deletions
diff --git a/app-i18n/fcitx-rime/Manifest b/app-i18n/fcitx-rime/Manifest
index 1086f4e2de20..27673f456cd9 100644
--- a/app-i18n/fcitx-rime/Manifest
+++ b/app-i18n/fcitx-rime/Manifest
@@ -1,4 +1,6 @@
DIST fcitx-rime-0.3.2.tar.xz 40960 BLAKE2B 1c9185dd9d2912e74b9916916fed09a01c30e0867d93fe94e04d5324883783dddbdca0f553d80aa19e2e59d2ec8fd2a50a7f89118c22cb09310296292a566760 SHA512 8c6d845b0899d9b8b9b41b895abd5c1b8916856b71f529aabd08d1c27a2b09bb5a9343912d088da460c2e22da0a3ce759a34fd13099a149bb8cd1ff4eafe29f1
+DIST fcitx-rime-5.1.4.tar.xz 49508 BLAKE2B e9846a0217b741d21c45ad4d6bd216f7d6afaec23ca71af3ab1dfffeeeba62eb85836592d53e70d0ce07217442164ccdecaa94eb36458d70778eb3d7e3bd1ada SHA512 1dc20c801e1ce4fa5e63f06554340af4616b044964d4235995e51dc6074223e30e66da74f354b2b05f77d2e0041af1e720bf2f2b214492ae4516d30761b2e092
EBUILD fcitx-rime-0.3.2.ebuild 946 BLAKE2B a98dc2a9b67926a75ac7b00debf6d85e42ad89689b1c6347e5b338017764e11d6b937474f8f0abd87da22add72697eb2bced2bfe1631c9d08cb11797a2ff45db SHA512 d0429288829c4de8f1b8b3c2c41a30716683e8126c3acc48fd5f3a1f90877419359fce74ece1e2acfcd3912eaed0dbca8bb9b4436b0667dc75a4a6e1dd807e47
EBUILD fcitx-rime-4.9999.ebuild 1226 BLAKE2B 46d921f42c0288e257346757bb9d376e665c58c2bbbf1a685ea24943caf401c0cefa3d8ea4abd4b21a5c49cf3e04f6a729e1ac37115b53fc21c777021980040b SHA512 fcbe4b1004193b8cef033e97fa87f4c25804baecf17ea02948d15569038292c9b4be9cfee913195acf2cdd2dc5486e187c3abfe8fd69fbd5dc3bb37e1515c9e4
-MISC metadata.xml 648 BLAKE2B d987ea8c401ae6fcbbdf68976ff90e58acf7f48472017e53b87f5e54008c82563e3f883771841a6dfc830d79b5845ae0a6dd3672cbcecc74a306e77e4f926d11 SHA512 05c594f82b34686d22f7a775955ccfba692733a6eeaadb4373383527a9e96bf749a22eb5b5ea91431b8c8e711d057a02024a3d8daae3c40e0e7c1832d7fe1469
+EBUILD fcitx-rime-5.1.4.ebuild 650 BLAKE2B 901f63c90ed3e800a5ef0b77089c53782cb5e418d9669dc0e3816343d5ab6017d94d1ab13d492585a424ccd1ebd41474b939048b333f3385d930cf9e2a5a2ad0 SHA512 dfdc42fb09f63c659b0e127185765fd30c05528783a264f4c7d8bbc4da94b086d1d49fada2adb15a08eaca19ea4809f9d8b7564484ce4ed1134c7189c5b506e9
+MISC metadata.xml 1077 BLAKE2B 762313960f3129b8d5b073ab755f5bc589c02c9f35287f33334a4e35fc9dfb8e05f1580f2da66d790dbf8734824af8a32a7894c729e5b06f18083de0b9c6c45e SHA512 fc07c97eab3f227fe9c09557854d91c24e6b13bf5b3d8d8cd630fb9b5c989af8adfd8e6012cf8de2c21cc7f2a1a5eeba560a084084c428a017964a254f42977a
diff --git a/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild b/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild
new file mode 100644
index 000000000000..9285cd4196a8
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+MY_PN="fcitx5-rime"
+DESCRIPTION="Chinese RIME input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-rime"
+SRC_URI="https://download.fcitx-im.org/fcitx5/fcitx5-rime/fcitx5-rime-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=app-i18n/fcitx-5.1.2:5
+ app-i18n/librime
+ app-i18n/rime-data
+ virtual/libintl
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
diff --git a/app-i18n/fcitx-rime/metadata.xml b/app-i18n/fcitx-rime/metadata.xml
index 30cc81a4df31..30d736fc8eac 100644
--- a/app-i18n/fcitx-rime/metadata.xml
+++ b/app-i18n/fcitx-rime/metadata.xml
@@ -2,6 +2,18 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>i@bitbili.net</email>
+ <name>Ryan Qian</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
<email>arfrever.fta@gmail.com</email>
<name>Arfrever Frehtes Taifersar Arahesis</name>
</maintainer>
@@ -17,6 +29,7 @@
<flag name="configuration_tool">Install configuration tool</flag>
</use>
<upstream>
+ <remote-id type="github">fcitx/fcitx5-rime</remote-id>
<remote-id type="github">fcitx/fcitx-rime</remote-id>
</upstream>
</pkgmetadata>