summaryrefslogtreecommitdiff
path: root/app-i18n/ibus/ibus-1.5.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus/ibus-1.5.12.ebuild')
-rw-r--r--app-i18n/ibus/ibus-1.5.12.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-i18n/ibus/ibus-1.5.12.ebuild b/app-i18n/ibus/ibus-1.5.12.ebuild
index a8413c59fff3..b3d6a397f2ce 100644
--- a/app-i18n/ibus/ibus-1.5.12.ebuild
+++ b/app-i18n/ibus/ibus-1.5.12.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
VALA_USE_DEPEND="vapigen"
-inherit autotools bash-completion-r1 gnome2-utils ltprune python-r1 vala virtualx
+inherit autotools bash-completion-r1 gnome2-utils python-r1 vala virtualx xdg-utils
DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
HOMEPAGE="https://github.com/ibus/ibus/wiki"
@@ -19,7 +19,6 @@ REQUIRED_USE="gtk2? ( gtk )
libnotify? ( gtk )
python? (
${PYTHON_REQUIRED_USE}
- gtk
introspection
)
test? ( gtk )
@@ -87,6 +86,7 @@ src_prepare() {
default
eautoreconf
+ xdg_environment_reset
}
src_configure() {
@@ -123,7 +123,7 @@ src_test() {
src_install() {
default
- prune_libtool_files --modules
+ find "${ED}" -name '*.la' -delete || die
if use python; then
python_install() {