summaryrefslogtreecommitdiff
path: root/app-i18n/transifex-client/transifex-client-0.12.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/transifex-client/transifex-client-0.12.4.ebuild')
-rw-r--r--app-i18n/transifex-client/transifex-client-0.12.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-i18n/transifex-client/transifex-client-0.12.4.ebuild b/app-i18n/transifex-client/transifex-client-0.12.4.ebuild
new file mode 100644
index 000000000000..1123e4d9a247
--- /dev/null
+++ b/app-i18n/transifex-client/transifex-client-0.12.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A command line interface for Transifex"
+HOMEPAGE="https://pypi.org/project/transifex-client/ http://www.transifex.net/"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}