summaryrefslogtreecommitdiff
path: root/app-i18n/translate-shell/translate-shell-0.9.6.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/translate-shell/translate-shell-0.9.6.8.ebuild')
-rw-r--r--app-i18n/translate-shell/translate-shell-0.9.6.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-i18n/translate-shell/translate-shell-0.9.6.8.ebuild b/app-i18n/translate-shell/translate-shell-0.9.6.8.ebuild
new file mode 100644
index 000000000000..ed36659409bf
--- /dev/null
+++ b/app-i18n/translate-shell/translate-shell-0.9.6.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Online command-line translator"
+HOMEPAGE="https://www.soimort.org/translate-shell/"
+SRC_URI="https://github.com/soimort/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+curl +bidi test tts"
+
+RDEPEND="
+ app-misc/rlwrap
+ >=sys-apps/gawk-4.0.2
+ curl? ( net-misc/curl[ssl] )
+ bidi? ( dev-libs/fribidi )
+ tts? ( || (
+ media-sound/mpg123
+ app-accessibility/espeak
+ media-video/mpv
+ media-video/mplayer
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( app-editors/emacs )
+ "
+
+src_test() {
+ emake NETWORK_ACCESS=no test
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+}