summaryrefslogtreecommitdiff
path: root/app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch')
-rw-r--r--app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch b/app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch
new file mode 100644
index 000000000000..bc1d8713cd22
--- /dev/null
+++ b/app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch
@@ -0,0 +1,24 @@
+diff -ruN zhcon-0.2.5/src/Makefile.am /tmp/zhcon-0.2.5/src/Makefile.am
+--- a/zhcon-0.2.5/src/Makefile.am 2006-06-22 12:35:01.531885552 +0800
++++ b/zhcon-0.2.5/src/Makefile.am 2006-06-22 12:31:44.000000000 +0800
+@@ -5,6 +5,8 @@
+
+ zhcon_LDADD = display/libdisplay.a
+
++zhcon_CPPFLAGS = -DSYSCONF_DIR=\"${sysconfdir}\"
++
+ SUBDIRS = display
+
+ install-exec-local:
+diff -ruN zhcon-0.2.5/src/zhcon.cpp /tmp/zhcon-0.2.5/src/zhcon.cpp
+--- a/zhcon-0.2.5/src/zhcon.cpp 2006-06-22 12:35:01.398905768 +0800
++++ b/zhcon-0.2.5/src/zhcon.cpp 2006-06-22 12:32:41.000000000 +0800
+@@ -123,7 +123,7 @@
+ string cfgfile = getenv("HOME");
+ cfgfile += "/.zhconrc";
+ if (access(cfgfile.c_str(), R_OK) != 0)
+- cfgfile = PREFIX "/etc/zhcon.conf";
++ cfgfile = SYSCONF_DIR"/zhcon.conf";
+
+ //for debug,a pause enable us to attach zhcon's pid in gdb
+ //char c;cin>>c;