summaryrefslogtreecommitdiff
path: root/app-laptop/dispad/dispad-0.3.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/dispad/dispad-0.3.1-r1.ebuild')
-rw-r--r--app-laptop/dispad/dispad-0.3.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-laptop/dispad/dispad-0.3.1-r1.ebuild b/app-laptop/dispad/dispad-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..f2e739c0d3a1
--- /dev/null
+++ b/app-laptop/dispad/dispad-0.3.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Daemon to disable trackpads while typing"
+HOMEPAGE="https://github.com/BlueDragonX/dispad"
+SRC_URI="https://github.com/BlueDragonX/dispad/tarball/v${PV/_/-} -> ${P}.tar.gz"
+
+S="${WORKDIR}/BlueDragonX-dispad-dbb9be3"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/confuse
+ x11-libs/libX11
+ x11-libs/libXi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf -i
+}