summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-azoth
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-azoth')
-rw-r--r--app-leechcraft/lc-azoth/Manifest2
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-9999.ebuild116
-rw-r--r--app-leechcraft/lc-azoth/metadata.xml41
3 files changed, 159 insertions, 0 deletions
diff --git a/app-leechcraft/lc-azoth/Manifest b/app-leechcraft/lc-azoth/Manifest
new file mode 100644
index 000000000000..ace0c044e3ce
--- /dev/null
+++ b/app-leechcraft/lc-azoth/Manifest
@@ -0,0 +1,2 @@
+EBUILD lc-azoth-9999.ebuild 3280 BLAKE2B d270545578eb2ad14e08095c211baf7c2288108d1619c9a157da87a3ce173e9b088b4567556350ef0f4d24a2f26255fa531d04fd275962a14589384a83ea242a SHA512 91d31dfb82dfb54db1e1828541a300c2e1b4cae041a315b5ab98ebc38984dc8ce46d9045eef78cc9f175f4752a0d816aa826091d3e8df57d30540bb5793d0d65
+MISC metadata.xml 2745 BLAKE2B ffe3572258b2c69a044c6a9361854254b1478a94027483dedd02cb095ecf1c771d7cfaff9f5ed51658508a7458123bc6e44698a7b4a2166fafee49ff8d2bc924 SHA512 08671df19283608de9e5d56c52c89bc2ee3741dd4e281fcdb1f4b159d77c30d80c248092772e700cb6901460838934db53787e3ff0dd109698a17502f8be4b63
diff --git a/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
new file mode 100644
index 000000000000..0eadc74c2bcd
--- /dev/null
+++ b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug doc +acetamide +adiumstyles astrality +autoidler +autopaste +birthdaynotifier
+ +chathistory +crypt +depester +embedmedia +herbicide +hili +isterique +juick
+ +keeso +lastseen +latex media +metacontacts +murm +nativeemoticons +otroid sarin
+ shx +spell +standardstyles +vader velvetbird +woodpecker +xmpp +xtazy"
+
+REQUIRED_USE="|| ( standardstyles adiumstyles )"
+
+COMMON_DEPEND="
+ ~app-leechcraft/lc-core-${PV}
+ dev-qt/qtdbus:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtxml:5
+ astrality? ( net-libs/telepathy-qt[qt5(+)] )
+ autoidler? (
+ dev-qt/qtx11extras:5
+ x11-libs/libXScrnSaver
+ )
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ lastseen? ( dev-qt/qtconcurrent:5 )
+ media? ( dev-qt/qtmultimedia:5 )
+ otroid? (
+ dev-qt/qtconcurrent:5
+ net-libs/libotr
+ )
+ sarin? (
+ dev-qt/qtconcurrent:5
+ net-libs/tox
+ )
+ woodpecker? ( dev-libs/kqoauth )
+ xmpp? (
+ >=net-libs/qxmpp-0.9.3-r1
+ media? ( net-libs/qxmpp[speex] )
+ )
+ xtazy? ( ~app-leechcraft/lc-xtazy-${PV} )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen[dot] )
+"
+RDEPEND="${COMMON_DEPEND}
+ astrality? (
+ net-im/telepathy-mission-control
+ net-voip/telepathy-haze
+ )
+ crypt? ( app-crypt/qca:2[gpg] )
+ latex? (
+ virtual/imagemagick-tools
+ virtual/latex-base
+ )
+ spell? ( ~app-leechcraft/lc-rosenthal-${PV} )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CRYPT=$(usex crypt)
+ -DWITH_DOCS=$(usex doc)
+ -DENABLE_AZOTH_ACETAMIDE=$(usex acetamide)
+ -DENABLE_AZOTH_ADIUMSTYLES=$(usex adiumstyles)
+ -DENABLE_AZOTH_ASTRALITY=$(usex astrality)
+ -DENABLE_AZOTH_AUTOIDLER=$(usex autoidler)
+ -DENABLE_AZOTH_AUTOPASTE=$(usex autopaste)
+ -DENABLE_AZOTH_BIRTHDAYNOTIFIER=$(usex birthdaynotifier)
+ -DENABLE_AZOTH_CHATHISTORY=$(usex chathistory)
+ -DENABLE_AZOTH_DEPESTER=$(usex depester)
+ -DENABLE_AZOTH_EMBEDMEDIA=$(usex embedmedia)
+ -DENABLE_AZOTH_HERBICIDE=$(usex herbicide)
+ -DENABLE_AZOTH_HILI=$(usex hili)
+ -DENABLE_AZOTH_ISTERIQUE=$(usex isterique)
+ -DENABLE_AZOTH_JUICK=$(usex juick)
+ -DENABLE_AZOTH_KEESO=$(usex keeso)
+ -DENABLE_AZOTH_LASTSEEN=$(usex lastseen)
+ -DENABLE_AZOTH_MODNOK=$(usex latex)
+ -DENABLE_AZOTH_METACONTACTS=$(usex metacontacts)
+ -DENABLE_MEDIACALLS=$(usex media)
+ -DENABLE_AZOTH_MURM=$(usex murm)
+ -DENABLE_AZOTH_NATIVEEMOTICONS=$(usex nativeemoticons)
+ -DENABLE_AZOTH_OTROID=$(usex otroid)
+ -DENABLE_AZOTH_SARIN=$(usex sarin)
+ -DENABLE_AZOTH_SHX=$(usex shx)
+ -DENABLE_AZOTH_ROSENTHAL=$(usex spell)
+ -DENABLE_AZOTH_STANDARDSTYLES=$(usex standardstyles)
+ -DENABLE_AZOTH_VADER=$(usex vader)
+ -DENABLE_AZOTH_VELVETBIRD=$(usex velvetbird)
+ -DENABLE_AZOTH_WOODPECKER=$(usex woodpecker)
+ -DENABLE_AZOTH_XOOX=$(usex xmpp)
+ -DENABLE_AZOTH_XTAZY=$(usex xtazy)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${CMAKE_BUILD_DIR}"/out/html/*
+}
+
+pkg_postinst() {
+ if use spell; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}
diff --git a/app-leechcraft/lc-azoth/metadata.xml b/app-leechcraft/lc-azoth/metadata.xml
new file mode 100644
index 000000000000..25fbfb888be8
--- /dev/null
+++ b/app-leechcraft/lc-azoth/metadata.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="acetamide">Build Acetamide, the IRC protocol support</flag>
+ <flag name="adiumstyles">Build support for Adium styles</flag>
+ <flag name="astrality">Build Astrality, support for protocols provided by Telepathy</flag>
+ <flag name="autoidler">Build support for automatic status changing according to user idle time</flag>
+ <flag name="autopaste">Build Autopaste for pasting long texts to pastebins</flag>
+ <flag name="birthdaynotifier">Build Birthday Notifier for you to not forget about birthdays of your contacts.</flag>
+ <flag name="chathistory">Build ChatHistory which stories chat history</flag>
+ <flag name="depester">Build Depester which enables to ignore MUC participants</flag>
+ <flag name="embedmedia">Build EmbedMedia for embedding flash videos and images directly into chat windows</flag>
+ <flag name="herbicide">Build Herbicide, a basic antispam plugin</flag>
+ <flag name="hili">Build HiLi which allows to customize highlight settings in MUCs</flag>
+ <flag name="isterique">Build Isterique plugin for neutralizing excessive caps lock usage</flag>
+ <flag name="juick">Build plugin for the Juick.com microblogging service</flag>
+ <flag name="keeso">Build plugin for changing text into SoMEtHInG lIKe THiS</flag>
+ <flag name="lastseen">Build plugin for client-side recording of the last online/available time</flag>
+ <flag name="media">Enable media calls</flag>
+ <flag name="metacontacts">Build plugin for metacontacts support</flag>
+ <flag name="murm">Build Murm, the VKontakte messaging support via their native API (instead of XMPP)</flag>
+ <flag name="nativeemoticons">Build support for native Azoth's emoticons packs</flag>
+ <flag name="otroid">Build OTRoid, plugin for the Off-the-Record deniable encryption system</flag>
+ <flag name="sarin">Build Sarin, Tox protocol support module. Please add mva overlay to use <pkg>net-libs/tox</pkg></flag>
+ <flag name="shx">Build shell command executor plugin</flag>
+ <flag name="standardstyles">Build support for standard Azoth styles engine</flag>
+ <flag name="vader">Bulid Vader, the MRIM (Mail.Ru Agent) protocol support plugin</flag>
+ <flag name="velvetbird">Build support for protocols provided by libpurple</flag>
+ <flag name="woodpecker">Build Woodpecker, the Twitter client plugin</flag>
+ <flag name="xtazy">Build Xtazy for publishing currently playing tune</flag>
+ </use>
+</pkgmetadata>