summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-monocle/lc-monocle-9999.ebuild')
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
new file mode 100644
index 000000000000..fcd13b3dd384
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +djvu doc +fb2 +mobi +pdf +postscript"
+
+REQUIRED_USE="postscript? ( pdf )"
+
+CDEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtxml:5
+ pdf? ( app-text/poppler[qt5] )
+ djvu? ( app-text/djvu )"
+
+RDEPEND="${CDEPEND}
+ postscript? ( app-text/ghostscript-gpl )"
+
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_MONOCLE_SEEN=$(usex djvu)
+ -DWITH_DOCS=$(usex doc)
+ -DENABLE_MONOCLE_FXB=$(usex fb2)
+ -DENABLE_MONOCLE_DIK=$(usex mobi)
+ -DENABLE_MONOCLE_PDF=$(usex pdf)
+ -DENABLE_MONOCLE_POSTRUS=$(usex postscript)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${CMAKE_BUILD_DIR}"/out/html/*
+}