summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild')
-rw-r--r--app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild b/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
new file mode 100644
index 000000000000..362f8279c933
--- /dev/null
+++ b/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="MusicBrainz client plugin for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug acoustid"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ acoustid? ( media-libs/chromaprint )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MUSICZOMBIE_CHROMAPRINT=$(usex acoustid)
+ )
+ cmake-utils_src_configure
+}