summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-musiczombie
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-musiczombie')
-rw-r--r--app-leechcraft/lc-musiczombie/Manifest2
-rw-r--r--app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild12
2 files changed, 6 insertions, 8 deletions
diff --git a/app-leechcraft/lc-musiczombie/Manifest b/app-leechcraft/lc-musiczombie/Manifest
index 27d6787ec6a1..d1c694b10d43 100644
--- a/app-leechcraft/lc-musiczombie/Manifest
+++ b/app-leechcraft/lc-musiczombie/Manifest
@@ -1,2 +1,2 @@
-EBUILD lc-musiczombie-9999.ebuild 554 BLAKE2B 4febda27b68e1fb9fb8a6d34023d9b157bd0a028d7132c961e3853ca6741f96b108ab47273b846646248013b73762ca12c91c10ab1ebc89e0e6f4066c8a373d2 SHA512 3d36bfc737bdc878ce723c41bfd3cdfd1d208cc257eea947574a4d08fa72c373da2a6bd15e07d06120f794ea2567ff56ca36d51a28693ac856e78df9e4903841
+EBUILD lc-musiczombie-9999.ebuild 507 BLAKE2B 6bedd8e5cac92189492f8248b573ed3c964c5c433c0759a596046e18bffabcc56387411ac17d87748295bc00d48dcf262b7c6ab7d5100079763b938d811cca06 SHA512 f9457d34b19cd22d5362d0c49d9a4c1073b79bc4bad477ab58272036f939d791eb08f0e0b764061829497ac01b5f01dc053e752a1900d1bb6b395c40c569831c
MISC metadata.xml 476 BLAKE2B 01d39f15177fec3de9b7f634451e5e780a5b92caef3a5fe053cd191bca4604fc33ccfd47d6c93efac0f5fef46a72ff03563defc89d4e162c5377d81d7e120c03 SHA512 b2b6dd4bbc3f1f5b3c107888891196abbcfd982c97fa5f5109802bcb29f593a98dae15124fd1eed53e42667df8f4ea4d5fbbf29bccb4731ad05b7d429458af15
diff --git a/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild b/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
index 362f8279c933..9a98bff590d8 100644
--- a/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
+++ b/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit leechcraft
@@ -9,20 +9,18 @@ DESCRIPTION="MusicBrainz client plugin for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="debug acoustid"
+IUSE="acoustid debug"
DEPEND="~app-leechcraft/lc-core-${PV}
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
dev-qt/qtconcurrent:5
dev-qt/qtnetwork:5
dev-qt/qtxml:5
- acoustid? ( media-libs/chromaprint )"
+ acoustid? ( media-libs/chromaprint:= )"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
-DWITH_MUSICZOMBIE_CHROMAPRINT=$(usex acoustid)
)
- cmake-utils_src_configure
+ cmake_src_configure
}