summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild')
-rw-r--r--app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild b/app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild
new file mode 100644
index 000000000000..88f56dfa9b67
--- /dev/null
+++ b/app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit leechcraft
+
+DESCRIPTION="LeechCraft plugin for supporting cloud data storages like Google Drive"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="+dropbox +googledrive"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ local mycmakeargs=(
+ -DENABLE_NETSTOREMANAGER_DROPBOX=$(usex dropbox)
+ -DENABLE_NETSTOREMANAGER_GOOGLEDRIVE=$(usex googledrive)
+ )
+
+ cmake-utils_src_configure
+}