summaryrefslogtreecommitdiff
path: root/app-metrics/go-carbon/go-carbon-0.17.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-metrics/go-carbon/go-carbon-0.17.1.ebuild')
-rw-r--r--app-metrics/go-carbon/go-carbon-0.17.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-metrics/go-carbon/go-carbon-0.17.1.ebuild b/app-metrics/go-carbon/go-carbon-0.17.1.ebuild
new file mode 100644
index 000000000000..5b808efaa023
--- /dev/null
+++ b/app-metrics/go-carbon/go-carbon-0.17.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Golang implementation of Graphite/Carbon server"
+HOMEPAGE="https://github.com/go-graphite/go-carbon"
+SRC_URI="https://github.com/go-graphite/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ acct-group/carbon
+ acct-user/carbon"
+BDEPEND=""
+
+src_install() {
+ insinto /etc/go-carbon
+ doins "${S}"/go-carbon.conf.example
+ dobin go-carbon
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}