summaryrefslogtreecommitdiff
path: root/app-misc/cdspeed/cdspeed-0.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cdspeed/cdspeed-0.4-r1.ebuild')
-rw-r--r--app-misc/cdspeed/cdspeed-0.4-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/cdspeed/cdspeed-0.4-r1.ebuild b/app-misc/cdspeed/cdspeed-0.4-r1.ebuild
new file mode 100644
index 000000000000..9701b686d358
--- /dev/null
+++ b/app-misc/cdspeed/cdspeed-0.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Change the speed of your CD drive"
+HOMEPAGE="http://linuxfocus.org/~guido/"
+SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ~mips ppc x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -Wall -Wno-unused" CC=$(tc-getCC) \
+ || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install || die "emake install"
+ dodoc README
+}