summaryrefslogtreecommitdiff
path: root/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild')
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild b/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..211e7bbf46fe
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
+SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+S="${WORKDIR}"/${P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" install || die "make install failed"
+ dosym iso3166 /usr/bin/countrycodes || die
+ dosym iso3166.1 /usr/share/man/man1/countrycodes || die
+ dodoc ../doc/{Changelog,README} || die
+ prepman
+}