summaryrefslogtreecommitdiff
path: root/app-misc/gentoo-elections/gentoo-elections-0_p20190710.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gentoo-elections/gentoo-elections-0_p20190710.ebuild')
-rw-r--r--app-misc/gentoo-elections/gentoo-elections-0_p20190710.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/gentoo-elections/gentoo-elections-0_p20190710.ebuild b/app-misc/gentoo-elections/gentoo-elections-0_p20190710.ebuild
new file mode 100644
index 000000000000..719ceb3fa342
--- /dev/null
+++ b/app-misc/gentoo-elections/gentoo-elections-0_p20190710.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="elections-20e84ba8cc3b328fccdc15219540443315ef4c20"
+DESCRIPTION="Gentoo election control data and scripts"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elections.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/elections.git/snapshot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Carp-Always
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Scalar-List-Utils"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # delete obsolete, broken symlinks
+ find completed -name Votify.pm -delete || die
+}
+
+src_install() {
+ insinto /usr/lib/gentoo-elections
+ doins -r completed countify Votify.pm
+}