summaryrefslogtreecommitdiff
path: root/app-misc/hello
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/hello')
-rw-r--r--app-misc/hello/Manifest4
-rw-r--r--app-misc/hello/hello-2.12.ebuild19
-rw-r--r--app-misc/hello/metadata.xml10
3 files changed, 32 insertions, 1 deletions
diff --git a/app-misc/hello/Manifest b/app-misc/hello/Manifest
index c6e333c3bf90..794a8d48fa2c 100644
--- a/app-misc/hello/Manifest
+++ b/app-misc/hello/Manifest
@@ -1,3 +1,5 @@
DIST hello-2.11.tar.gz 1018256 BLAKE2B 6e06e4a3a113fc24bca056197ba004fd97b2076bb2f5d660f337782c9a982a0d80e265e7e1dc22f3467257eab071fe5e252a020234839f30ce767ae5d5ee7a3b SHA512 9b1defc1dd7b6a989d3f64a1cb1c6f47276192d7bacf11282ae8683606eb613473c882c1a5e74c18d641f46584f0735981597a45ae4eb37830a5b4d955e3aec7
+DIST hello-2.12.tar.gz 1017723 BLAKE2B 62a977d27c3e9a2a3d3998bf4f9b1dd8323d88a603138a80ad423d51493f9c99bed418dfc64ee55c23587d727865bf149affed6fe40b782d8ca9384346ba6414 SHA512 e22ff0733162d30e0daaf53c5b5663ab5ddb1cccbdac94591ac2abb53aa5e113141211596fa49706b7dcfdf3fbb96130c4326b1307dca0427b1768fe0ccf9fec
EBUILD hello-2.11.ebuild 472 BLAKE2B 9a8f5ca0fbb6eab9df429fb427c66c529d8cc933115a0d5fd823fd7fdc1f53d49baddb6ad4250e3395458107592b7b037abdbd44c3cbca96a8c8d28c9fb2207c SHA512 60ba38f778a6e506ef037711775a4829579e8392f1aa946e2a5ad9c9b8eeeb373cf99ed74ebccbbcac338e2c2e4e30c8ad9a4fe0d172b7a339d3ca825ea87bd9
-MISC metadata.xml 240 BLAKE2B b559293d1cef57841e20125c4e0bd1176639876be1247c7ad02d1609591cbf51288dc5f16217faa2744ab4d1e75dcfad91f208fb443c078a65350b9d3cafa41d SHA512 f970c0dc4306bfdaf616c0329da49487c838fd6e66b8f2c4b08b5161c2892c327c9261c669137d6aeb5a9dddddc2af150a8a7bb36a85e5c24074db6021998877
+EBUILD hello-2.12.ebuild 462 BLAKE2B da2528232fce08e2556595f63c7ce334b5cb55c199e2496b94342279b110c7f88f6cb7b5b70d7c9f92b12b2a587160a14d77e1985b1de4e33f6a09dd2b8f977d SHA512 d229242a4cc7225a58c0655bc83bd853f3fdaa5bd1b920e9e595da41f0f1d4d6c9ff9a54bd9ecc1b37fc95a737b367311a5fd063c4347ee743079ab9e8414182
+MISC metadata.xml 908 BLAKE2B 0f4529944e36f69d5909538c1a3b56b95f839add37eb1116b87f3a6d88e7c413b4665ddccbf34cbdb49ef7de40b1d2963093ba7ed57283f2065580360eb16bb7 SHA512 9ec733e92d44f8e0a58c8e4ec4a38101a066b65f0f327f8c6f792959b6a13825d7210d5138d51f7983ac972ac7d69f5c1facdc7ba49120397f033d811f44b377
diff --git a/app-misc/hello/hello-2.12.ebuild b/app-misc/hello/hello-2.12.ebuild
new file mode 100644
index 000000000000..8cdce7f78794
--- /dev/null
+++ b/app-misc/hello/hello-2.12.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="GNU \"Hello, world\" application"
+HOMEPAGE="https://www.gnu.org/software/hello/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+DOCS=( AUTHORS ChangeLog{,.O} NEWS README THANKS contrib/evolution.txt )
+
+src_configure() {
+ econf $(use_enable nls)
+}
diff --git a/app-misc/hello/metadata.xml b/app-misc/hello/metadata.xml
index 4b556c94c6a0..692681ffb756 100644
--- a/app-misc/hello/metadata.xml
+++ b/app-misc/hello/metadata.xml
@@ -2,7 +2,17 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
+ <longdescription>
+ The GNU Hello program produces a familiar, friendly greeting.
+ Yes, this is another implementation of the classic program that prints “Hello, world!” when you run it.
+
+ However, unlike the minimal version often seen, GNU Hello processes its argument list to modify its behavior,
+ supports greetings in many languages, and so on. The primary purpose of GNU Hello is to demonstrate how to
+ write other programs that do these things; it serves as a model for GNU coding standards and GNU maintainer practices.
+ </longdescription>
<upstream>
+ <bugs-to>mailto:bug-hello@gnu.org</bugs-to>
+ <doc>https://www.gnu.org/software/hello/manual/hello.html</doc>
<remote-id type="savannah">hello</remote-id>
</upstream>
</pkgmetadata>