summaryrefslogtreecommitdiff
path: root/app-misc/hivex/hivex-1.3.20.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/hivex/hivex-1.3.20.ebuild')
-rw-r--r--app-misc/hivex/hivex-1.3.20.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-misc/hivex/hivex-1.3.20.ebuild b/app-misc/hivex/hivex-1.3.20.ebuild
index 7c8d10963bbb..60d911612b9d 100644
--- a/app-misc/hivex/hivex-1.3.20.ebuild
+++ b/app-misc/hivex/hivex-1.3.20.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -65,6 +65,12 @@ src_unpack() {
cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all || die
}
+src_prepare() {
+ default
+ use perl && perl-module_src_prepare
+ use ruby && ruby-ng_src_prepare
+}
+
src_configure() {
use ruby && ruby-ng_src_configure