summaryrefslogtreecommitdiff
path: root/app-misc/imgurbash2/imgurbash2-2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/imgurbash2/imgurbash2-2.1.ebuild')
-rw-r--r--app-misc/imgurbash2/imgurbash2-2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/imgurbash2/imgurbash2-2.1.ebuild b/app-misc/imgurbash2/imgurbash2-2.1.ebuild
new file mode 100644
index 000000000000..076690d530e5
--- /dev/null
+++ b/app-misc/imgurbash2/imgurbash2-2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ram-on/imgurbash2.git"
+else
+ SRC_URI="https://github.com/ram-on/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Bash script that uploads/deletes images to/from imgur"
+HOMEPAGE="https://github.com/ram-on/imgurbash2"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+ net-misc/curl
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+"
+
+src_install() {
+ einstalldocs
+ dobin imgurbash2
+}