summaryrefslogtreecommitdiff
path: root/app-misc/jq/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/jq/files')
-rw-r--r--app-misc/jq/files/jq-1.7-runpath.patch17
-rw-r--r--app-misc/jq/files/jq-1.7-visible-null.patch41
-rw-r--r--app-misc/jq/files/jq-1.7-warnings.patch44
3 files changed, 102 insertions, 0 deletions
diff --git a/app-misc/jq/files/jq-1.7-runpath.patch b/app-misc/jq/files/jq-1.7-runpath.patch
new file mode 100644
index 000000000000..a8f76f7c90e1
--- /dev/null
+++ b/app-misc/jq/files/jq-1.7-runpath.patch
@@ -0,0 +1,17 @@
+diff --git a/configure.ac b/configure.ac
+index 0441d4a..8f1aa23 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -283,4 +283,11 @@ AC_SUBST([BUNDLER], ["$bundle_cmd"])
+ AC_CONFIG_MACRO_DIR([config/m4])
+ AC_CONFIG_FILES([Makefile libjq.pc])
+ AC_OUTPUT
+-
++AC_ARG_ENABLE([rpathhack],
++ [AC_HELP_STRING([--enable-rpathhack], [patch libtool to remove RPATH])],
++ [
++AC_MSG_RESULT([patching libtool to fix rpath])
++sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
++sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
++ ],
++ [])
diff --git a/app-misc/jq/files/jq-1.7-visible-null.patch b/app-misc/jq/files/jq-1.7-visible-null.patch
new file mode 100644
index 000000000000..41e55df72111
--- /dev/null
+++ b/app-misc/jq/files/jq-1.7-visible-null.patch
@@ -0,0 +1,41 @@
+diff --git a/src/jv_print.c b/src/jv_print.c
+index 2e781bb..e621b31 100644
+--- a/src/jv_print.c
++++ b/src/jv_print.c
+@@ -32,7 +32,7 @@ static const jv_kind color_kinds[] =
+ static char color_bufs[sizeof(color_kinds)/sizeof(color_kinds[0])][16];
+ static const char *color_bufps[8];
+ static const char* def_colors[] =
+- {COL("1;30"), COL("0;37"), COL("0;37"), COL("0;37"),
++ {COL("1;90"), COL("0;37"), COL("0;37"), COL("0;37"),
+ COL("0;32"), COL("1;37"), COL("1;37")};
+ #define FIELD_COLOR COL("34;1")
+
+diff --git a/tests/shtest b/tests/shtest
+index 8ed62b2..2d3f0da 100755
+--- a/tests/shtest
++++ b/tests/shtest
+@@ -280,12 +280,12 @@ fi
+
+ # Check $JQ_COLORS
+ $JQ -Ccn . > $d/color
+-printf '\033[1;30mnull\033[0m\n' > $d/expect
++printf '\033[1;90mnull\033[0m\n' > $d/expect
+ cmp $d/color $d/expect
+ JQ_COLORS='4;31' $JQ -Ccn . > $d/color
+ printf '\033[4;31mnull\033[0m\n' > $d/expect
+ cmp $d/color $d/expect
+-JQ_COLORS='1;30:0;31:0;32:0;33:0;34:1;35:1;36' \
++JQ_COLORS='1;90:0;31:0;32:0;33:0;34:1;35:1;36' \
+ $JQ -Ccn '[{"a":true,"b":false},123,null]' > $d/color
+ (
+ printf '\033[1;35m[\033[1;36m{'
+@@ -298,7 +298,7 @@ printf '[0m\033[0;31mfalse\033'
+ printf '[0m\033[1;36m\033[1;36'
+ printf 'm}\033[0m\033[1;35m,\033['
+ printf '0;33m123\033[0m\033[1;'
+-printf '35m,\033[1;30mnull\033'
++printf '35m,\033[1;90mnull\033'
+ printf '[0m\033[1;35m\033[1;35'
+ printf 'm]\033[0m\n'
+ ) > $d/expect
diff --git a/app-misc/jq/files/jq-1.7-warnings.patch b/app-misc/jq/files/jq-1.7-warnings.patch
new file mode 100644
index 000000000000..0047ca391cae
--- /dev/null
+++ b/app-misc/jq/files/jq-1.7-warnings.patch
@@ -0,0 +1,44 @@
+diff --git a/src/builtin.c b/src/builtin.c
+index bf80c7b..12db573 100644
+--- a/src/builtin.c
++++ b/src/builtin.c
+@@ -1,5 +1,6 @@
+ #define _BSD_SOURCE
+ #define _GNU_SOURCE
++#define _DEFAULT_SOURCE
+ #ifndef __sun__
+ # define _XOPEN_SOURCE
+ # define _XOPEN_SOURCE_EXTENDED 1
+diff --git a/src/jv_dtoa.c b/src/jv_dtoa.c
+index 33feb99..fcbd902 100644
+--- a/src/jv_dtoa.c
++++ b/src/jv_dtoa.c
+@@ -2327,7 +2327,7 @@ retlow1:
+ jvp_strtod
+ (struct dtoa_context* C, const char *s00, char **se)
+ {
+- int bb2, bb5, bbe, bd2, bd5, bbbits, bs2, c, e, e1, test_scale;
++ int bb2, bb5, bbe, bd2, bd5, bbbits, bs2, c, e, e1;
+ int esign, i, j, k, nd, nd0, nf, nz, nz0, nz1, sign;
+ CONST char *s, *s0, *s1;
+ double aadj, aadj1;
+diff --git a/src/jv_dtoa_tsd.c b/src/jv_dtoa_tsd.c
+index 0f95df4..e5209dd 100644
+--- a/src/jv_dtoa_tsd.c
++++ b/src/jv_dtoa_tsd.c
+@@ -24,7 +24,7 @@ static void tsd_dtoa_ctx_fini() {
+ }
+
+ static void tsd_dtoa_ctx_init() {
+- if (pthread_key_create(&dtoa_ctx_key, tsd_dtoa_ctx_dtor) != 0) {
++ if (pthread_key_create(&dtoa_ctx_key, (void (*)(void *))tsd_dtoa_ctx_dtor) != 0) {
+ fprintf(stderr, "error: cannot create thread specific key");
+ abort();
+ }
+@@ -43,4 +43,4 @@ inline struct dtoa_context *tsd_dtoa_context_get() {
+ }
+ }
+ return ctx;
+-}
+\ No newline at end of file
++}