summaryrefslogtreecommitdiff
path: root/app-misc/neofetch/neofetch-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/neofetch/neofetch-9999.ebuild')
-rw-r--r--app-misc/neofetch/neofetch-9999.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/app-misc/neofetch/neofetch-9999.ebuild b/app-misc/neofetch/neofetch-9999.ebuild
index b5f654d39b3b..b0c0a070de9b 100644
--- a/app-misc/neofetch/neofetch-9999.ebuild
+++ b/app-misc/neofetch/neofetch-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit prefix
+inherit optfeature prefix
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
@@ -17,17 +17,6 @@ DESCRIPTION="Simple information system script"
HOMEPAGE="https://github.com/dylanaraps/neofetch"
LICENSE="MIT-with-advertising"
SLOT="0"
-IUSE="X"
-
-RDEPEND="sys-apps/pciutils
- X? (
- media-gfx/imagemagick
- media-libs/imlib2
- www-client/w3m[imlib]
- x11-apps/xprop
- x11-apps/xrandr
- x11-apps/xwininfo
- )"
src_prepare() {
if use prefix; then
@@ -43,3 +32,11 @@ src_prepare() {
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+}