summaryrefslogtreecommitdiff
path: root/app-misc/pax-utils
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pax-utils')
-rw-r--r--app-misc/pax-utils/Manifest2
-rw-r--r--app-misc/pax-utils/files/pax-utils-1.2.3-python-3.7.patch32
-rw-r--r--app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild74
3 files changed, 108 insertions, 0 deletions
diff --git a/app-misc/pax-utils/Manifest b/app-misc/pax-utils/Manifest
index 85e7d2809837..bd7cf7246467 100644
--- a/app-misc/pax-utils/Manifest
+++ b/app-misc/pax-utils/Manifest
@@ -1,4 +1,6 @@
+AUX pax-utils-1.2.3-python-3.7.patch 899 BLAKE2B bc3037b78e7caea904b91c84d115cc7e1acf91019d74dfe1c1c9c44c900d835fe550adfce89140b991b96ea4d63267f48da7596f89cf7daf1c93e43d4e7f6924 SHA512 dcbe424084b8b0cfe77c461b5897cb027e30778f9283bcaef358d70e1496473cbb5b7ed7c55347859c86571b77f9aad4c051d1b519823efed6c9e6314defc187
DIST pax-utils-1.2.3.tar.xz 661828 BLAKE2B 4764c47b7a31e7470a454127b9db3b5b27c703a96a66973a6248529a2d858ea38adb246a270a1f343a499515f55b25613bb20c46978e2e0dddc03e5ddb9a2aa7 SHA512 efcbce49aa7e5cd433f9b3fbc8fa82f6d7b0eb80ec40aafde453d6fe96e3565e066e5020f04d71537d8d4e820147f4203c0df2dd330ebb1358a26def3dd5484c
EBUILD pax-utils-1.2.3-r2.ebuild 1765 BLAKE2B 37602b6c4593bbc53e8b1905647881e0d4454b5bf192b90b00d66506b1c7b57a38cf00d9b126cceff0a96ea245e2a6236ba79675e4a6653e9de9565033714738 SHA512 bbfc6232f0d1d2c81fe39ed35a74d6a7f0f66ef136112f44f8317438047d210e13770b251d9fb446b16b65bb97b9fab18c2a62749d106b9e71bbb9440e214932
+EBUILD pax-utils-1.2.3-r3.ebuild 1812 BLAKE2B c6322cc812a3db52f81ad7495ac9753c29be6f2f5287c97112fe1ed0052e5b345c8e9c8290b261def4a63ca4183d1408d5c448d206a3e231142984173c5db55e SHA512 62661ca64ac3dad190af9cc4c5035e9a4b8c39c21d75cdc354000f0f465b093b39b63690b3ee297f623649a516a994830cac5bc51f76a5a623c3e62290a9598b
EBUILD pax-utils-1.2.3.ebuild 1477 BLAKE2B e3e27277bcf7d95983713cb31a0a57b998d500d42d26ba75b364b42da9b3c9b82635b02148daba3e675a816b446b2d9ec09b851635b5800712d1bd61d594211f SHA512 a407d1613f4489687d3d86bae6fb9bf8f527fb123fbd59e56ac9f390e80de5063610e76ca2570b78fb35e05abed5c735939599e7604265aed68185f4cf49e731
MISC metadata.xml 706 BLAKE2B 1660bd83c0164ecb4c187d6271cd1f27a8140906bef315bcfc4be37594f91a79cfa9da8fb9dfd1af66c6c7028ed4d40ef891b025fb12b9486b7ee366a3e5c354 SHA512 3691bf431cb24ad3498b137f0e264562451db583201e1cae327ed201f36d838f01dfe78e3569a2d24593c67f747dff17eec645bacf0855148c72354ebeaa26f1
diff --git a/app-misc/pax-utils/files/pax-utils-1.2.3-python-3.7.patch b/app-misc/pax-utils/files/pax-utils-1.2.3-python-3.7.patch
new file mode 100644
index 000000000000..40fff21c022c
--- /dev/null
+++ b/app-misc/pax-utils/files/pax-utils-1.2.3-python-3.7.patch
@@ -0,0 +1,32 @@
+From 2acc5c3278354f56c70f9f48e66eb0203d5e8370 Mon Sep 17 00:00:00 2001
+From: Oleksandr Natalenko <oleksandr@natalenko.name>
+Date: Sat, 17 Nov 2018 15:43:09 +0100
+Subject: [PATCH] lddtree.py: use errno properly
+
+os.errno interface is removed [1], thus should not be used. In fact, it
+is not used in other places of lddtree.py, so fix this one too, because
+it breaks --copy-to-tree on systems with Python 3.7.
+
+[1] https://bugs.python.org/issue33666
+
+Bug: https://bugs.gentoo.org/671522
+Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ lddtree.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/lddtree.py
++++ b/lddtree.py
+@@ -122,7 +122,7 @@ def makedirs(path):
+ try:
+ os.makedirs(path)
+ except OSError as e:
+- if e.errno != os.errno.EEXIST:
++ if e.errno != errno.EEXIST:
+ raise
+
+
+--
+2.19.2
+
diff --git a/app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild b/app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild
new file mode 100644
index 000000000000..880abaa929a9
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit eutils python-single-r1 toolchain-funcs unpacker
+
+DESCRIPTION="ELF utils that can check files for security relevant properties"
+HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="caps debug python seccomp"
+
+RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ )
+ seccomp? ( sys-libs/libseccomp )"
+DEPEND="${RDEPEND}
+ caps? ( virtual/pkgconfig )
+ seccomp? ( virtual/pkgconfig )
+ app-arch/xz-utils"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python-3.7.patch
+)
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_DEBUG=$(usex debug) \
+ USE_PYTHON=$(usex python) \
+ USE_SECCOMP=$(usex seccomp) \
+ "$@"
+}
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux ||
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
+ else
+ tc-export CC PKG_CONFIG
+ fi
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+
+ use python && python_fix_shebang "${ED}"/usr/bin/lddtree
+}