summaryrefslogtreecommitdiff
path: root/app-misc/votrify/votrify-1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/votrify/votrify-1.ebuild')
-rw-r--r--app-misc/votrify/votrify-1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/votrify/votrify-1.ebuild b/app-misc/votrify/votrify-1.ebuild
new file mode 100644
index 000000000000..f067073ac0cc
--- /dev/null
+++ b/app-misc/votrify/votrify-1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Tool for community verification of Gentoo elections"
+HOMEPAGE="https://github.com/mgorny/votrify"
+SRC_URI="https://github.com/mgorny/votrify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-misc/gentoo-elections"
+
+src_configure() {
+ # update default location for election scripts
+ sed -i -e "s^os.path.dirname(__file__)^'${EPREFIX}/usr/lib'^" \
+ make-confirmation.py || die
+
+ # update script names
+ sed -i -e 's:\(./\)\?\(make-confirmation\|verify-confirmations\).py:votrify-\2:g' \
+ README.rst || die
+
+ python_fix_shebang *.py
+}
+
+src_install() {
+ newbin make-confirmation.py votrify-make-confirmation
+ newbin verify-confirmations.py votrify-verify-confirmations
+ einstalldocs
+}