summaryrefslogtreecommitdiff
path: root/app-office/gtg/files/gtg-0.3.1-locales.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/gtg/files/gtg-0.3.1-locales.patch')
-rw-r--r--app-office/gtg/files/gtg-0.3.1-locales.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-office/gtg/files/gtg-0.3.1-locales.patch b/app-office/gtg/files/gtg-0.3.1-locales.patch
new file mode 100644
index 000000000000..56bf5ce5e9b1
--- /dev/null
+++ b/app-office/gtg/files/gtg-0.3.1-locales.patch
@@ -0,0 +1,20 @@
+Do not install unwanted locales.
+
+--- a/setup.py 2014-11-01 11:21:49.679613605 +0100
++++ b/setup.py 2014-11-01 11:26:36.305719135 +0100
+@@ -101,9 +101,15 @@
+
+ PO_DIR = 'po'
+ MO_DIR = os.path.join('build', 'po')
++LINGUAS = os.environ.get('LINGUAS', '*').split(' ')
+
+ for po in glob.glob(os.path.join(PO_DIR, '*.po')):
+ lang = os.path.basename(po[:-3])
++
++ # Skip unwanted locales
++ if lang not in LINGUAS and '*' not in LINGUAS:
++ continue
++
+ mo = os.path.join(MO_DIR, lang, 'gtg.mo')
+ target_dir = os.path.dirname(mo)
+ if not os.path.isdir(target_dir):