summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/files')
-rw-r--r--app-office/libreoffice/files/libreoffice-24.2-unused-qt6network.patch57
-rw-r--r--app-office/libreoffice/files/libreoffice-7.6-unused-qt5network.patch58
-rw-r--r--app-office/libreoffice/files/libreoffice-7.6.6.1-detect-plasma6.patch153
3 files changed, 115 insertions, 153 deletions
diff --git a/app-office/libreoffice/files/libreoffice-24.2-unused-qt6network.patch b/app-office/libreoffice/files/libreoffice-24.2-unused-qt6network.patch
new file mode 100644
index 000000000000..ccb69f22654e
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-24.2-unused-qt6network.patch
@@ -0,0 +1,57 @@
+From d4287704f9e2ea07e0750b114ec0761c2732d03e Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 12 Mar 2024 21:40:25 +0100
+Subject: [PATCH] Drop unused QtNetwork dependency, fix KDE terminology
+
+'KDE version' -> 'KDE Frameworks version'
+
+Change-Id: I2e6a912be93d79b251dcf32c20796374c9ca9cf2
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ configure.ac | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6d56df8625f1..9d6b35b747e5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -13341,7 +13341,7 @@ then
+
+ QT6_CFLAGS="-I$qt6_incdir -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT -DQT_NO_VERSION_TAGGING"
+ QT6_CFLAGS=$(printf '%s' "$QT6_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
+- QT6_LIBS="-L$qt6_libdir -lQt6Core -lQt6Gui -lQt6Widgets -lQt6Network"
++ QT6_LIBS="-L$qt6_libdir -lQt6Core -lQt6Gui -lQt6Widgets"
+ if test "$_os" = "Emscripten"; then
+ QT6_LIBS="$QT6_LIBS -lQt6BundledPcre2 -lQt6BundledZLIB -L${qt6_platformsdir} -lqwasm -sGL_ENABLE_GET_PROC_ADDRESS"
+ fi
+@@ -13521,15 +13521,15 @@ then
+ AC_MSG_ERROR([KF6 libraries not found. Please specify the root of your KF6 installation by exporting KF6DIR before running "configure".])
+ fi
+
+- KF6_CFLAGS="-I$kf6_incdir -I$kf6_incdir/KCoreAddons -I$kf6_incdir/KI18n -I$kf6_incdir/KConfig -I$kf6_incdir/KConfigCore -I$kf6_incdir/KWindowSystem -I$kf6_incdir/KIO -I$kf6_incdir/KIOCore -I$kf6_incdir/KIOWidgets -I$kf6_incdir/KIOFileWidgets -I$qt6_incdir -I$qt6_incdir/QtCore -I$qt6_incdir/QtGui -I$qt6_incdir/QtWidgets -I$qt6_incdir/QtNetwork -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT -DQT_NO_VERSION_TAGGING"
+- KF6_LIBS="-L$kf6_libdir -lKF6CoreAddons -lKF6I18n -lKF6ConfigCore -lKF6WindowSystem -lKF6KIOCore -lKF6KIOWidgets -lKF6KIOFileWidgets -L$qt6_libdir -lQt6Core -lQt6Gui -lQt6Widgets -lQt6Network"
++ KF6_CFLAGS="-I$kf6_incdir -I$kf6_incdir/KCoreAddons -I$kf6_incdir/KI18n -I$kf6_incdir/KConfig -I$kf6_incdir/KConfigCore -I$kf6_incdir/KWindowSystem -I$kf6_incdir/KIO -I$kf6_incdir/KIOCore -I$kf6_incdir/KIOWidgets -I$kf6_incdir/KIOFileWidgets -I$qt6_incdir -I$qt6_incdir/QtCore -I$qt6_incdir/QtGui -I$qt6_incdir/QtWidgets -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT -DQT_NO_VERSION_TAGGING"
++ KF6_LIBS="-L$kf6_libdir -lKF6CoreAddons -lKF6I18n -lKF6ConfigCore -lKF6WindowSystem -lKF6KIOCore -lKF6KIOWidgets -lKF6KIOFileWidgets -L$qt6_libdir -lQt6Core -lQt6Gui -lQt6Widgets"
+ KF6_CFLAGS=$(printf '%s' "$KF6_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
+
+ AC_LANG_PUSH([C++])
+ save_CXXFLAGS=$CXXFLAGS
+ CXXFLAGS="$CXXFLAGS $KF6_CFLAGS"
+ dnl KF6 development version as of 2023-06 uses version number 5.240
+- AC_MSG_CHECKING([whether KDE is >= 5.240])
++ AC_MSG_CHECKING([whether KDE Frameworks is >= 5.240])
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <kcoreaddons_version.h>
+
+@@ -13537,7 +13537,7 @@ int main(int argc, char **argv) {
+ if (KCOREADDONS_VERSION_MAJOR == 6 || (KCOREADDONS_VERSION_MAJOR == 5 && KCOREADDONS_VERSION_MINOR >= 240)) return 0;
+ else return 1;
+ }
+- ]])],[AC_MSG_RESULT([yes])],[AC_MSG_ERROR([KDE version too old])],[])
++ ]])],[AC_MSG_RESULT([yes])],[AC_MSG_ERROR([KDE Frameworks version too old])],[])
+ CXXFLAGS=$save_CXXFLAGS
+ AC_LANG_POP([C++])
+ fi
+--
+2.44.0
+
diff --git a/app-office/libreoffice/files/libreoffice-7.6-unused-qt5network.patch b/app-office/libreoffice/files/libreoffice-7.6-unused-qt5network.patch
new file mode 100644
index 000000000000..edeb38854994
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-7.6-unused-qt5network.patch
@@ -0,0 +1,58 @@
+From d4287704f9e2ea07e0750b114ec0761c2732d03e Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 12 Mar 2024 21:40:25 +0100
+Subject: [PATCH] Drop unused QtNetwork dependency, fix KDE terminology
+
+'KDE version' -> 'KDE Frameworks version'
+
+Change-Id: I2e6a912be93d79b251dcf32c20796374c9ca9cf2
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ configure.ac | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6d56df8625f1..9d6b35b747e5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -13213,7 +13213,7 @@ then
+
+ QT5_CFLAGS="-I$qt5_incdir -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT -DQT_NO_VERSION_TAGGING"
+ QT5_CFLAGS=$(printf '%s' "$QT5_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
+- QT5_LIBS="-L$qt5_libdir -lQt5Core -lQt5Gui -lQt5Widgets -lQt5Network"
++ QT5_LIBS="-L$qt5_libdir -lQt5Core -lQt5Gui -lQt5Widgets"
+ if test "$_os" = "Emscripten"; then
+ QT5_LIBS="$QT5_LIBS -lqtpcre2 -lQt5EventDispatcherSupport -lQt5FontDatabaseSupport -L${qt5_platformsdir} -lqwasm"
+ fi
+@@ -13442,8 +13442,8 @@ then
+ AC_MSG_ERROR([KF5 libraries not found. Please specify the root of your KF5 installation by exporting KF5DIR before running "configure".])
+ fi
+
+- KF5_CFLAGS="-I$kf5_incdir -I$kf5_incdir/KCoreAddons -I$kf5_incdir/KI18n -I$kf5_incdir/KConfigCore -I$kf5_incdir/KWindowSystem -I$kf5_incdir/KIOCore -I$kf5_incdir/KIOWidgets -I$kf5_incdir/KIOFileWidgets -I$qt5_incdir -I$qt5_incdir/QtCore -I$qt5_incdir/QtGui -I$qt5_incdir/QtWidgets -I$qt5_incdir/QtNetwork -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT -DQT_NO_VERSION_TAGGING"
+- KF5_LIBS="-L$kf5_libdir -lKF5CoreAddons -lKF5I18n -lKF5ConfigCore -lKF5WindowSystem -lKF5KIOCore -lKF5KIOWidgets -lKF5KIOFileWidgets -L$qt5_libdir -lQt5Core -lQt5Gui -lQt5Widgets -lQt5Network"
++ KF5_CFLAGS="-I$kf5_incdir -I$kf5_incdir/KCoreAddons -I$kf5_incdir/KI18n -I$kf5_incdir/KConfigCore -I$kf5_incdir/KWindowSystem -I$kf5_incdir/KIOCore -I$kf5_incdir/KIOWidgets -I$kf5_incdir/KIOFileWidgets -I$qt5_incdir -I$qt5_incdir/QtCore -I$qt5_incdir/QtGui -I$qt5_incdir/QtWidgets -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT -DQT_NO_VERSION_TAGGING"
++ KF5_LIBS="-L$kf5_libdir -lKF5CoreAddons -lKF5I18n -lKF5ConfigCore -lKF5WindowSystem -lKF5KIOCore -lKF5KIOWidgets -lKF5KIOFileWidgets -L$qt5_libdir -lQt5Core -lQt5Gui -lQt5Widgets"
+ KF5_CFLAGS=$(printf '%s' "$KF5_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
+
+ if test "$USING_X11" = TRUE; then
+@@ -13453,7 +13453,7 @@ then
+ AC_LANG_PUSH([C++])
+ save_CXXFLAGS=$CXXFLAGS
+ CXXFLAGS="$CXXFLAGS $KF5_CFLAGS"
+- AC_MSG_CHECKING([whether KDE is >= 5.0])
++ AC_MSG_CHECKING([whether KDE Frameworks is >= 5.0])
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <kcoreaddons_version.h>
+
+@@ -13461,7 +13461,7 @@ int main(int argc, char **argv) {
+ if (KCOREADDONS_VERSION_MAJOR == 5 && KCOREADDONS_VERSION_MINOR >= 0) return 0;
+ else return 1;
+ }
+- ]])],[AC_MSG_RESULT([yes])],[AC_MSG_ERROR([KDE version too old])],[])
++ ]])],[AC_MSG_RESULT([yes])],[AC_MSG_ERROR([KDE Frameworks version too old])],[])
+ CXXFLAGS=$save_CXXFLAGS
+ AC_LANG_POP([C++])
+ fi
+--
+2.44.0
+
diff --git a/app-office/libreoffice/files/libreoffice-7.6.6.1-detect-plasma6.patch b/app-office/libreoffice/files/libreoffice-7.6.6.1-detect-plasma6.patch
deleted file mode 100644
index 9a4553db3447..000000000000
--- a/app-office/libreoffice/files/libreoffice-7.6.6.1-detect-plasma6.patch
+++ /dev/null
@@ -1,153 +0,0 @@
-From 4c836645eb0556a496c80e4604b63b47085020dd Mon Sep 17 00:00:00 2001
-From: Michael Weghorn <m.weghorn@posteo.de>
-Date: Thu, 22 Jun 2023 08:40:56 +0200
-Subject: [PATCH] Detect Plasma 6 desktop
-
-Add detection for Plasma 6, which is currently in development stage.
-With the following plasma-workspace commit [1] in place,
-KDE_SESSION_VERSION is set to 6, so use that to detect it:
-
- commit 4c2242d7dfafac161baec3ec316af24d7b48ef8b
- Author: Michael Weghorn <m.weghorn@posteo.de>
- Date: Thu Jun 22 07:47:31 2023 +0200
-
- Set KDE_SESSION_VERSION to 6
-
- Since the master branch is based on Qt6/KF6 and will
- become Plasma 6, set KDE_SESSION_VERSION to "6".
-
- This will allow other applications to detect they're
- running in a (preview of a) Plasma 6 session and react
- accordingly.
- (E.g. LibreOffice can use this to choose to
- use its upcoming kf6 integration by default instead of the
- kf5 one.)
-
-[1] https://invent.kde.org/plasma/plasma-workspace/-/commit/4c2242d7dfafac161baec3ec316af24d7b48ef8b
-
-Change-Id: I5a15ad1fb177721fbfa016139c56a08b228f2e1f
-Reviewed-on: https://gerrit.libreoffice.org/c/core/+/153437
-Tested-by: Jenkins
-Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
-(cherry picked from commit 8b0e1f2a914d672182d585d8cb2d4a815e88977e)
-Reviewed-on: https://gerrit.libreoffice.org/c/core/+/164700
-Reviewed-by: Adolfo Jayme Barrientos <fitojb@ubuntu.com>
----
- vcl/inc/unx/desktops.hxx | 1 +
- vcl/source/app/IconThemeSelector.cxx | 1 +
- vcl/source/app/salplug.cxx | 4 ++--
- vcl/unx/generic/desktopdetect/desktopdetector.cxx | 11 +++++++++++
- vcl/unx/kf5/KF5SalInstance.cxx | 8 +++++---
- 5 files changed, 20 insertions(+), 5 deletions(-)
-
-diff --git a/vcl/inc/unx/desktops.hxx b/vcl/inc/unx/desktops.hxx
-index 0abb6aa71339..2056c2c37928 100644
---- a/vcl/inc/unx/desktops.hxx
-+++ b/vcl/inc/unx/desktops.hxx
-@@ -33,6 +33,7 @@ enum SAL_DLLPUBLIC_RTTI DesktopType
- DESKTOP_XFCE,
- DESKTOP_MATE,
- DESKTOP_PLASMA5,
-+ DESKTOP_PLASMA6,
- DESKTOP_LXQT
- }; // keep in sync with desktop_strings[] in salplug.cxx
-
-diff --git a/vcl/source/app/IconThemeSelector.cxx b/vcl/source/app/IconThemeSelector.cxx
-index 6b8dfc0f42c7..15eb4b7768fc 100644
---- a/vcl/source/app/IconThemeSelector.cxx
-+++ b/vcl/source/app/IconThemeSelector.cxx
-@@ -70,6 +70,7 @@ IconThemeSelector::GetIconThemeForDesktopEnvironment(const OUString& desktopEnvi
- #else
- OUString r;
- if ( desktopEnvironment.equalsIgnoreAsciiCase("plasma5") ||
-+ desktopEnvironment.equalsIgnoreAsciiCase("plasma6") ||
- desktopEnvironment.equalsIgnoreAsciiCase("lxqt") ) {
- if (!bPreferDarkIconTheme)
- r = "breeze";
-diff --git a/vcl/source/app/salplug.cxx b/vcl/source/app/salplug.cxx
-index e51375b94ae5..fee5b7e33e6d 100644
---- a/vcl/source/app/salplug.cxx
-+++ b/vcl/source/app/salplug.cxx
-@@ -249,7 +249,7 @@ const char* const* autodetect_plugin_list()
- desktop == DESKTOP_XFCE ||
- desktop == DESKTOP_MATE )
- pList = pStandardFallbackList;
-- else if (desktop == DESKTOP_PLASMA5 || desktop == DESKTOP_LXQT)
-+ else if (desktop == DESKTOP_PLASMA5 || desktop == DESKTOP_PLASMA6 || desktop == DESKTOP_LXQT)
- pList = pKDEFallbackList;
-
- return pList;
-@@ -426,7 +426,7 @@ const OUString& SalGetDesktopEnvironment()
- // Order to match desktops.hxx' DesktopType
- static const char * const desktop_strings[] = {
- "none", "unknown", "GNOME", "UNITY",
-- "XFCE", "MATE", "PLASMA5", "LXQT" };
-+ "XFCE", "MATE", "PLASMA5", "PLASMA6", "LXQT" };
- static OUString aDesktopEnvironment;
- if( aDesktopEnvironment.isEmpty())
- {
-diff --git a/vcl/unx/generic/desktopdetect/desktopdetector.cxx b/vcl/unx/generic/desktopdetect/desktopdetector.cxx
-index bad134fbdafd..8baeb303feed 100644
---- a/vcl/unx/generic/desktopdetect/desktopdetector.cxx
-+++ b/vcl/unx/generic/desktopdetect/desktopdetector.cxx
-@@ -117,6 +117,13 @@ static bool is_plasma5_desktop()
- return pFullVersion && pSessionVersion && (0 == strcmp(pSessionVersion, "5"));
- }
-
-+static bool is_plasma6_desktop()
-+{
-+ static const char* pFullVersion = getenv("KDE_FULL_SESSION");
-+ static const char* pSessionVersion = getenv("KDE_SESSION_VERSION");
-+ return pFullVersion && pSessionVersion && (0 == strcmp(pSessionVersion, "6"));
-+}
-+
- extern "C"
- {
-
-@@ -132,6 +139,8 @@ DESKTOP_DETECTOR_PUBLIC DesktopType get_desktop_environment()
- return DESKTOP_LXQT;
- if (aOver.equalsIgnoreAsciiCase("plasma5") || aOver.equalsIgnoreAsciiCase("plasma"))
- return DESKTOP_PLASMA5;
-+ if (aOver.equalsIgnoreAsciiCase("plasma6"))
-+ return DESKTOP_PLASMA6;
- if ( aOver.equalsIgnoreAsciiCase( "gnome" ) )
- return DESKTOP_GNOME;
- if ( aOver.equalsIgnoreAsciiCase( "gnome-wayland" ) )
-@@ -190,6 +199,8 @@ DESKTOP_DETECTOR_PUBLIC DesktopType get_desktop_environment()
-
- if (is_plasma5_desktop())
- return DESKTOP_PLASMA5;
-+ if (is_plasma6_desktop())
-+ return DESKTOP_PLASMA6;
-
- // tdf#121275 if we still can't tell, and WAYLAND_DISPLAY
- // is set, default to gtk3
-diff --git a/vcl/unx/kf5/KF5SalInstance.cxx b/vcl/unx/kf5/KF5SalInstance.cxx
-index df5108e147a1..05f555f356f5 100644
---- a/vcl/unx/kf5/KF5SalInstance.cxx
-+++ b/vcl/unx/kf5/KF5SalInstance.cxx
-@@ -41,7 +41,8 @@ KF5SalInstance::KF5SalInstance(std::unique_ptr<QApplication>& pQApp, bool bUseCa
-
- bool KF5SalInstance::hasNativeFileSelection() const
- {
-- if (Application::GetDesktopEnvironment() == "PLASMA5")
-+ const OUString sDesktop = Application::GetDesktopEnvironment();
-+ if (sDesktop == "PLASMA5" || sDesktop == "PLASMA6")
- return true;
- return QtInstance::hasNativeFileSelection();
- }
-@@ -61,8 +62,9 @@ KF5SalInstance::createPicker(css::uno::Reference<css::uno::XComponentContext> co
-
- // In order to insert custom controls, KF5FilePicker currently relies on KFileWidget
- // being used in the native file picker, which is only the case for KDE Plasma.
-- // Therefore, return the plain qt5 one in order to not lose custom controls.
-- if (Application::GetDesktopEnvironment() == "PLASMA5")
-+ // Therefore, return the plain qt5/qt6 one in order to not lose custom controls otherwise.
-+ const OUString sDesktop = Application::GetDesktopEnvironment();
-+ if (sDesktop == "PLASMA5" || sDesktop == "PLASMA6")
- return new KF5FilePicker(context, eMode);
- return QtInstance::createPicker(context, eMode);
- }
---
-2.44.0
-