summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-6.2.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-6.2.9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-6.2.9999.ebuild30
1 files changed, 11 insertions, 19 deletions
diff --git a/app-office/libreoffice/libreoffice-6.2.9999.ebuild b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
index 12765a8bb8cd..4b4ea02af443 100644
--- a/app-office/libreoffice/libreoffice-6.2.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
@@ -18,10 +18,10 @@ DEV_URI="
ADDONS_URI="https://dev-www.libreoffice.org/src/"
BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
-PATCHSET="${PN}-6.2.0.3-patchset-02.tar.xz"
+PATCHSET="${PN}-6.2.1.1-patchset-01.tar.xz"
[[ ${MY_PV} == *9999* ]] && inherit git-r3
-inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic gnome2-utils java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg-utils
+inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg
DESCRIPTION="A full office productivity suite"
HOMEPAGE="https://www.libreoffice.org"
@@ -63,7 +63,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
-googledrive gstreamer +gtk gtk2 kde +mariadb odk pdfimport postgres test vlc
+googledrive gstreamer +gtk gtk2 kde ldap +mariadb odk pdfimport postgres test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -133,7 +133,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
media-libs/libzmf
net-libs/neon
net-misc/curl
- net-nds/openldap
sci-mathematics/lpsolve
sys-libs/zlib
virtual/glu
@@ -185,6 +184,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
kde-frameworks/kio:5
kde-frameworks/kwindowsystem:5
)
+ ldap? ( net-nds/openldap )
libreoffice_extensions_scripting-beanshell? ( dev-java/bsh )
libreoffice_extensions_scripting-javascript? ( dev-java/rhino:1.6 )
mariadb? ( dev-db/mariadb-connector-c )
@@ -247,9 +247,8 @@ DEPEND="${COMMON_DEPEND}
PATCHES=(
# master branch
- "${WORKDIR}"/${PATCHSET/.tar.xz/}/011-qt5-change-salgraphics-gettextlayout-def.patch
- "${WORKDIR}"/${PATCHSET/.tar.xz/}/013-qt5-assert-missing-salgraphics-font-on-gettextlayout.patch
- "${WORKDIR}"/${PATCHSET/.tar.xz/}/019-drop-kde4-desktop-detection.patch
+ "${FILESDIR}/${PN}-6.2-ldap-optional.patch"
+ "${WORKDIR}"/${PATCHSET/.tar.xz/}
# not upstreamable stuff
"${FILESDIR}/${PN}-5.4-system-pyuno.patch"
@@ -285,7 +284,6 @@ pkg_pretend() {
pkg_setup() {
java-pkg-opt-2_pkg_setup
python-single-r1_pkg_setup
- xdg_environment_reset
[[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_setup
}
@@ -309,7 +307,7 @@ src_unpack() {
}
src_prepare() {
- default
+ xdg_src_prepare
# sandbox violations on many systems, we don't need it. Bug #646406
sed -i \
@@ -445,6 +443,7 @@ src_configure() {
$(use_enable gtk2 gtk)
$(use_enable kde kde5)
$(use_enable kde qt5)
+ $(use_enable ldap)
$(use_enable odk)
$(use_enable pdfimport)
$(use_enable postgres postgresql-sdbc)
@@ -568,14 +567,7 @@ src_install() {
pax-mark -m "${ED%/}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
}
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
+pkg_preinst() {
+ java-utils-2_pkg_preinst
+ xdg_pkg_preinst
}