summaryrefslogtreecommitdiff
path: root/app-office/onlyoffice-bin
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/onlyoffice-bin')
-rw-r--r--app-office/onlyoffice-bin/Manifest2
-rw-r--r--app-office/onlyoffice-bin/onlyoffice-bin-8.3.1.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-office/onlyoffice-bin/Manifest b/app-office/onlyoffice-bin/Manifest
index 64cc773c3bc7..e9c5c94afab5 100644
--- a/app-office/onlyoffice-bin/Manifest
+++ b/app-office/onlyoffice-bin/Manifest
@@ -1,5 +1,7 @@
DIST onlyoffice-bin-8.2.2_amd64.deb 283250472 BLAKE2B ea4a66b337297e68ecb3a0ec9692640454d84849b991df11891d085f3e23df2023432be251f2c2bd7c63240d75db3e29982ac02ae87b0d66223ec21557ae6f7d SHA512 34e58e1f35e63c28b264756918e11cba38c66b1de9a0f7c4bed62ea34f5c891923fed80ccb26301ae21e6f2111e03f5251d3a1a052d9c4a0b1ac47f1a9653b4e
DIST onlyoffice-bin-8.3.0_amd64.deb 288699292 BLAKE2B 0dbda0e98004f87911c9ce58558db4f2cae9f3aabaf7d7259a106a1ddb98755c80c3f1568ff1542752ff6161d93867b04308b56d50cf6ae83552a6ee792496d7 SHA512 262e65613ff13f16767cf6f1350d27ffe5c9894956318ff3a513d9a032c6c3cfdc879a05e3b4deb7c214392e90f1e271350c35a52045ac08daf6a76de656f29e
+DIST onlyoffice-bin-8.3.1_amd64.deb 288553876 BLAKE2B e27ae4e05d3202098aa38f0e79f8f144c2aaf8c880fe19113de608f27ccf82c9d9854dc9eef94d873b87b2faaba80512f0f5a076a0583586d58c8dc98b6c89df SHA512 82fd15b29cf89d4deb6ed84db41576a075d06bb2db354affa6f806e5348863829ca06284876dc245985ab43882a97f95f9443800e51c2e11009b941c82676e26
EBUILD onlyoffice-bin-8.2.2.ebuild 1928 BLAKE2B 92b38733a96d5d97132ec4b3688ff94aa548f34249a64a6034842c5f2ca3f04f10e2393331fda3ce87c09a564f77cfe7332ef721a3b9741fe36115a57df97310 SHA512 db5f0234018a111cead535f705b36e75044dafd82a12680afa78627f09bb0e06d9eb4b013969d7d4327077f5c46108290076435bcf0a2f250c7419631982950c
EBUILD onlyoffice-bin-8.3.0.ebuild 1907 BLAKE2B 16b7ca67e2cbf51683072c03e14e7af02147731173cef3452657df0aeb9fdfc2cb5a24cd0d23cd8acaf1f576f3abf5b48b406c25db87059f2a97a2b8d9dc811b SHA512 ecabdacc9906a147df8ce77e0b1b0b6bf38878672755c0ca2338fdb6ebbde93ae27c4db5a067465fd8d6642f1c1ab98034cb226d673ceb71373006eab0fca4c8
+EBUILD onlyoffice-bin-8.3.1.ebuild 1907 BLAKE2B 16b7ca67e2cbf51683072c03e14e7af02147731173cef3452657df0aeb9fdfc2cb5a24cd0d23cd8acaf1f576f3abf5b48b406c25db87059f2a97a2b8d9dc811b SHA512 ecabdacc9906a147df8ce77e0b1b0b6bf38878672755c0ca2338fdb6ebbde93ae27c4db5a067465fd8d6642f1c1ab98034cb226d673ceb71373006eab0fca4c8
MISC metadata.xml 446 BLAKE2B d5d01751407be4985806d5dc9f973f8333d34e8cb9428702c9580038530668b82153e3fd83b7e8f93d74ec45c28e3f9802690e1aa38b7ad2b0da489325092104 SHA512 896aa89e2b98b724154cfbb1321a681a219217b78cd96fe163d587c2a2c167e7bfc18cf75ce3b93eb723098699db95d92a45d0a2cb79931d9a45dc571a315a45
diff --git a/app-office/onlyoffice-bin/onlyoffice-bin-8.3.1.ebuild b/app-office/onlyoffice-bin/onlyoffice-bin-8.3.1.ebuild
new file mode 100644
index 000000000000..ae2d74e6a36e
--- /dev/null
+++ b/app-office/onlyoffice-bin/onlyoffice-bin-8.3.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+MY_P="ONLYOFFICE-DesktopEditors-"${PV}""
+
+DESCRIPTION="Onlyoffice is an office productivity suite (binary version)"
+HOMEPAGE="https://www.onlyoffice.com/"
+SRC_URI="
+ amd64? (
+ https://github.com/ONLYOFFICE/DesktopEditors/releases/download/v"${PV}"/onlyoffice-desktopeditors_amd64.deb
+ -> "${P}"_amd64.deb
+ )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror strip test"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5[eglfs]
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/libglvnd
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-devel/gcc
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ || (
+ media-libs/libpulse
+ media-sound/apulse
+ )
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Allow launching the ONLYOFFICE on ALSA systems via media-sound/apulse
+ sed -i -e "/^export LD_LIBRARY_PATH=/ s|$|:${EPREFIX}/usr/$(get_libdir)/apulse|" \
+ "${S}"/usr/bin/onlyoffice-desktopeditors || die
+}
+
+src_install() {
+ domenu usr/share/applications/onlyoffice-desktopeditors.desktop
+ for size in {16,24,32,48,64,128,256}; do
+ doicon -s ${size} usr/share/icons/hicolor/${size}x${size}/apps/onlyoffice-desktopeditors.png
+ done
+
+ dobin usr/bin/desktopeditors usr/bin/onlyoffice-desktopeditors
+ doins -r opt
+ fperms +x /opt/onlyoffice/desktopeditors/{DesktopEditors,editors_helper,converter/x2t}
+}