summaryrefslogtreecommitdiff
path: root/app-portage/pram/pram-7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/pram/pram-7.ebuild')
-rw-r--r--app-portage/pram/pram-7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-portage/pram/pram-7.ebuild b/app-portage/pram/pram-7.ebuild
new file mode 100644
index 000000000000..515d0a342fb1
--- /dev/null
+++ b/app-portage/pram/pram-7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Tool to ease merging Pull Requests and git patches"
+HOMEPAGE="https://github.com/mgorny/pram"
+SRC_URI="https://github.com/mgorny/pram/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-vcs/git
+ net-misc/wget[ssl]
+ virtual/editor
+ !dev-perl/Gentoo-App-Pram"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ app-crypt/gnupg
+ sys-apps/diffutils
+ )"