summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-5.0_p18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-5.0_p18.ebuild')
-rw-r--r--app-shells/bash/bash-5.0_p18.ebuild9
1 files changed, 0 insertions, 9 deletions
diff --git a/app-shells/bash/bash-5.0_p18.ebuild b/app-shells/bash/bash-5.0_p18.ebuild
index 3ea29fe66b10..ab801c88333f 100644
--- a/app-shells/bash/bash-5.0_p18.ebuild
+++ b/app-shells/bash/bash-5.0_p18.ebuild
@@ -255,15 +255,6 @@ pkg_preinst() {
mkdir -p "${EROOT}"/etc/bash
mv -f "${EROOT}"/etc/bashrc "${EROOT}"/etc/bash/
fi
-
- if [[ -L ${EROOT}/bin/sh ]] ; then
- # rewrite the symlink to ensure that its mtime changes. having /bin/sh
- # missing even temporarily causes a fatal error with paludis.
- local target=$(readlink "${EROOT}"/bin/sh)
- local tmp="${T}"/sh
- ln -sf "${target}" "${tmp}"
- mv -f "${tmp}" "${EROOT}"/bin/sh
- fi
}
pkg_postinst() {