summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-5.1_p16-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-5.1_p16-r5.ebuild')
-rw-r--r--app-shells/bash/bash-5.1_p16-r5.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/app-shells/bash/bash-5.1_p16-r5.ebuild b/app-shells/bash/bash-5.1_p16-r5.ebuild
index c617e503f113..230aaaf033a5 100644
--- a/app-shells/bash/bash-5.1_p16-r5.ebuild
+++ b/app-shells/bash/bash-5.1_p16-r5.ebuild
@@ -45,21 +45,27 @@ if is_release ; then
# bash-5.1 -> bash51
my_p=${PN}$(ver_rs 1-2 '' $(ver_cut 1-2))
- patch_url=
+ patch_url=
my_patch_index=
+ upstream_url_base="mirror://gnu/bash"
+ mirror_url_base="ftp://ftp.cwru.edu/pub/bash"
+
for ((my_patch_index=1; my_patch_index <= ${PLEVEL} ; my_patch_index++)) ; do
- for url in mirror://gnu/${pn} ftp://ftp.cwru.edu/pub/bash ; do
- patch_url=$(printf "${url}/${PN}-$(ver_cut 1-2)-patches/${my_p}-%03d" ${my_patch_index})
- SRC_URI+=" ${patch_url}"
- SRC_URI+=" verify-sig? ( ${patch_url}.sig )"
+ printf -v mangled_patch_ver ${my_p}-%03d ${my_patch_index}
+ patch_url="${upstream_url_base}/${MY_P}-patches/${mangled_patch_ver}"
- done
+ SRC_URI+=" ${patch_url}"
+ SRC_URI+=" verify-sig? ( ${patch_url}.sig )"
+
+ # Add in the mirror URL too.
+ SRC_URI+=" ${patch_url/${upstream_url_base}/${mirror_url_base}}"
+ SRC_URI+=" verify-sig? ( ${patch_url/${upstream_url_base}/${mirror_url_base}} )"
- MY_PATCHES+=( "${DISTDIR}"/$(printf ${my_p}-%03d ${my_patch_index}) )
+ MY_PATCHES+=( "${DISTDIR}"/${mangled_patch_ver} )
done
- unset my_pn patch_url my_patch_index
+ unset my_p patch_url my_patch_index upstream_url_base mirror_url_base
fi
else
SRC_URI="ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz"