summaryrefslogtreecommitdiff
path: root/app-shells/ccsh/ccsh-0.0.4-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/ccsh/ccsh-0.0.4-r5.ebuild')
-rw-r--r--app-shells/ccsh/ccsh-0.0.4-r5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-shells/ccsh/ccsh-0.0.4-r5.ebuild b/app-shells/ccsh/ccsh-0.0.4-r5.ebuild
new file mode 100644
index 000000000000..c8b2106df52f
--- /dev/null
+++ b/app-shells/ccsh/ccsh-0.0.4-r5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="UNIX Shell for people already familiar with the C language"
+HOMEPAGE="https://ccsh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ccsh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ exeinto /bin
+ doexe "${PN}"
+ newman "${PN}.man" "${PN}.1"
+ dodoc ChangeLog README TODO
+}