summaryrefslogtreecommitdiff
path: root/app-shells/esh
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/esh')
-rw-r--r--app-shells/esh/Manifest3
-rw-r--r--app-shells/esh/esh-0.8.5-r3.ebuild (renamed from app-shells/esh/esh-0.8.5-r2.ebuild)11
-rw-r--r--app-shells/esh/files/esh-0.8.5-fix-build-for-clang16.patch38
3 files changed, 48 insertions, 4 deletions
diff --git a/app-shells/esh/Manifest b/app-shells/esh/Manifest
index c2992e7ec5e2..3ae65bc1a7bf 100644
--- a/app-shells/esh/Manifest
+++ b/app-shells/esh/Manifest
@@ -1,3 +1,4 @@
+AUX esh-0.8.5-fix-build-for-clang16.patch 1017 BLAKE2B 96c9e5663227932e09b3a46a3256afafb3c1b64131be571d5d37251bf9832877f724a678e0605678da62e250195f2a0d66daccd5a2deb23b97fef47fd28c178e SHA512 fd0b8f4949e1146d79eae7b3e3db83e95cfe2e3e9a77213a5b9814abf7d82ba79972dacfefc94ddbe46a1ab6707122bf7df3fa7cb609c35203242746ebb568d4
DIST esh-0.8.5.tar.gz 214040 BLAKE2B 8fbcfed21a9dc156f496cd650e1f7d4242f869d753b147070e51c357531353b9028de7cd405334e7171f805bf048d032310063e8fe2776de976557b080b2946e SHA512 2473cc2418f70533136305f47dfe59bee560206a8b58c080e2113297dd82483e867937bda1b015069a7220552b4d03346a3b71026a24a2795b0b499e355490a0
-EBUILD esh-0.8.5-r2.ebuild 1370 BLAKE2B c47baedc53b8f8bff6107e86a991982d2db0835e7c1c4642ae5eaaf4d6527fab07549d18edf1bfd8fd78c25ee2bbcd519d721473124c3db4e61cce2399e4dedc SHA512 1ee1334d77d6ecc635afb098a15e50480492da6fa26c7c72f4da842e0d542aaf4f583fc6413ebe9a0d19e018c47bb817ccc8b9f2737fd4b6c3d55477f102da2b
+EBUILD esh-0.8.5-r3.ebuild 1432 BLAKE2B 237d10daf695ec9e16ed279dea941ce6bdf842ac0528141a28d3666396e4421e1726aeb460b4a2af8ae7f815fe11e5a816d481f5ee4ca0a56377ba335ca424aa SHA512 9bc91d0a7419e1bbf0a3321a0c1ca915cad2c63a901adf6f099526207404d54891e6775357b4457b222c49435633ca9eea0e16c0ba07cf22a794384e9943375a
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-shells/esh/esh-0.8.5-r2.ebuild b/app-shells/esh/esh-0.8.5-r3.ebuild
index 164a969d91f4..29ed1611a7a0 100644
--- a/app-shells/esh/esh-0.8.5-r2.ebuild
+++ b/app-shells/esh/esh-0.8.5-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit flag-o-matic toolchain-funcs
@@ -19,13 +19,18 @@ DEPEND=">=sys-libs/readline-4.1:="
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-for-clang16.patch
+)
+
src_prepare() {
- default
# For some reason, this tarball has binary files in it for x86.
# Make clean so we can rebuild for our arch and optimization.
emake clean
+ default
+
sed -i \
-e 's|-g ||' \
-e 's|-DMEM_DEBUG ||' \
diff --git a/app-shells/esh/files/esh-0.8.5-fix-build-for-clang16.patch b/app-shells/esh/files/esh-0.8.5-fix-build-for-clang16.patch
new file mode 100644
index 000000000000..1d87f583f53a
--- /dev/null
+++ b/app-shells/esh/files/esh-0.8.5-fix-build-for-clang16.patch
@@ -0,0 +1,38 @@
+This fixes the build for clang16.
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+
+diff --git a/hash.c b/hash.c
+index f3d7a3d..cf3c25a 100644
+--- a/hash.c
++++ b/hash.c
+@@ -148,7 +148,7 @@ void hash_init(hash_table* _hash_array, hash_entry data[]) {
+ }
+
+ void hash_free(hash_table* tab,
+- void (*func)()) {
++ void (*func)(void* data)) {
+ int i;
+ list* iter;
+
+
+--- a/read-rl.c
++++ b/read-rl.c
+@@ -99,7 +99,7 @@ static char** rl_esh_completion(char* word, int start, int end) {
+ }
+
+ if (openparen(rl_line_buffer[start])) {
+- return completion_matches(word, rl_find_builtin);
++ return rl_completion_matches(word, (rl_compentry_func_t *)rl_find_builtin);
+
+ } else {
+ return NULL;
+@@ -110,7 +110,7 @@ void read_init(void) {
+ rl_bind_key('\012', rl_literal_newline);
+
+ /* rl_catch_signals = 0; */
+- rl_attempted_completion_function = rl_esh_completion;
++ rl_attempted_completion_function = (rl_completion_func_t *)rl_esh_completion;
+ }
+
+ char* read_read(char* prompt) {