summaryrefslogtreecommitdiff
path: root/app-shells/ksh/ksh-93.20180215.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/ksh/ksh-93.20180215.ebuild')
-rw-r--r--app-shells/ksh/ksh-93.20180215.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/ksh/ksh-93.20180215.ebuild b/app-shells/ksh/ksh-93.20180215.ebuild
new file mode 100644
index 000000000000..576ab31e881e
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20180215.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson prefix
+
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="http://www.kornshell.com/"
+
+COMMIT="e3dd5b1a4b1bf58a018bbd9c8626b15113b72717"
+SRC_URI="https://github.com/att/ast/archive/${COMMIT}/${P}.tar.gz"
+
+LICENSE="CPL-1.0 EPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!app-shells/pdksh"
+
+S="${WORKDIR}/ast-${COMMIT}"
+
+PATCHES=(
+ "${FILESDIR}"/ksh-prefix-r1.patch
+)
+
+src_prepare() {
+ default
+ eprefixify src/cmd/ksh93/data/msg.c
+}
+
+src_install() {
+ meson_src_install
+ dodir /bin
+ mv "${ED%/}"{/usr,}/bin/ksh || die
+}