summaryrefslogtreecommitdiff
path: root/app-shells/ksh/ksh-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/ksh/ksh-9999.ebuild')
-rw-r--r--app-shells/ksh/ksh-9999.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-shells/ksh/ksh-9999.ebuild b/app-shells/ksh/ksh-9999.ebuild
index 2ccad3528bf3..9e136daa8efa 100644
--- a/app-shells/ksh/ksh-9999.ebuild
+++ b/app-shells/ksh/ksh-9999.ebuild
@@ -24,6 +24,19 @@ SLOT="0"
RDEPEND="!app-shells/pdksh"
+src_test() {
+ # https://bugs.gentoo.org/702570
+ addwrite /proc/self
+ local cmd=(
+ meson test
+ -C "${BUILD_DIR}"
+ --num-processes "$(makeopts_jobs ${NINJAOPTS:-${MAKEOPTS}})"
+ )
+ echo "${cmd[@]}" >&2
+ # https://github.com/att/ast/issues/1392
+ env -u T "${cmd[@]}" || die
+}
+
src_install() {
meson_src_install
dodir /bin