summaryrefslogtreecommitdiff
path: root/app-shells/loksh
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/loksh')
-rw-r--r--app-shells/loksh/Manifest6
-rw-r--r--app-shells/loksh/loksh-7.5.ebuild21
-rw-r--r--app-shells/loksh/loksh-7.6.ebuild41
-rw-r--r--app-shells/loksh/metadata.xml7
4 files changed, 67 insertions, 8 deletions
diff --git a/app-shells/loksh/Manifest b/app-shells/loksh/Manifest
index 70ca0c3f20f1..8198cd8db31d 100644
--- a/app-shells/loksh/Manifest
+++ b/app-shells/loksh/Manifest
@@ -1,3 +1,5 @@
DIST loksh-7.5.tar.xz 212104 BLAKE2B c5897860ca9ce7614921e890ec2ba6f464f600df9410082256e7b4cb53c15fbacb2f46fb8eada77910c19a260338f8e2fb55e3b324c96ab82e44f502859769a2 SHA512 9aee8219a4d63d06c95df2347611a04664ec344c2cb4c3d5d14bdea6b9cabc424246b0e070c901b4a5e38f5784b2c43f5c3c78b01f74cbdce46eded6fda043db
-EBUILD loksh-7.5.ebuild 608 BLAKE2B e8c20811e3ada7b68b8378e52b88605bbbd9ec0e4e76ef4c9688d30cb08dd09ce03bee3bdd4b281d2539f769f9f8f2eb01ccd2939befb945bf40a2fab3cf9631 SHA512 a3a869de0e915164a41a6f58bceb571577693eba77cc7cbfa1205a94fa5a0e23dd81c4c6df96fb7344251d772f30403f45c2f36ea96bda286f72251c3557f142
-MISC metadata.xml 249 BLAKE2B 142b02b03c614d9c821dc6367b16318494fecdb5b0f172c52661feb0239a404b6de757087be48910eeccba582942fcf4fc8adc95b665446d2d82d858536ec0e6 SHA512 cb8b29b51403536e9e2dad9337a0310d1f57123c9684c8372dacefccb23e389ba32c7e090efdb6404d1641b2b5a356bf11dd4f48b70f99f233700ce4b10db9aa
+DIST loksh-7.6.tar.xz 212080 BLAKE2B 845fbda4b0ff17c432a6ab2b506ad02bc2f9a36873d20ba3ab7b4bf5eeff6609f61c0223f9d18933314bca22b45c02313cdab6cb69bed73227918516b8be186a SHA512 c03a298e93bff3c689591a9864eeb5daa661b6b0b783102a271f7ebb08297a4939d8c923233fc23892b83c86d7102f9ae022f4b4d3fdf33e095e86690014fb24
+EBUILD loksh-7.5.ebuild 728 BLAKE2B 620c34d0c5a2832cdcb8f134b7cc0d33bb9a9cce35c47e9cb16cde22e0559cf1b28ac83d22760abea0cae8e071f41a2aa4557101601c0e65c016ecd68d5eeb8e SHA512 57af241f1f30937f7cbc773b35e121fd98d32f1095d3a60814b4db14d4f13058b00b6904c15bf151f525b8102e6f32950d95911e28a207577f0d1731ea43630b
+EBUILD loksh-7.6.ebuild 730 BLAKE2B 7a790f5a3dee5a2dd9122d5ee10975580997833443b7c43b995c815ad83e880970b1d9c9f47333785383884839cb86e328e3f5c51e79becdce72d5173e46c69e SHA512 fab27234f749b5068c9eabb1ad89d4098ef9c0bfd0a4f8f2912546192a49ec72e4dbf45d11573255787bd466dda81ab6865aef079fe3d3975be84ac01afb9cfc
+MISC metadata.xml 393 BLAKE2B f13c9b5bd5fb387fd3bc7997fc2582e8c4aab50f12d8d8f869d00d15cf25eb42ebb3119ecfe20613c21761c8644a2910c4b4412e83ded7237b8183a461580e9c SHA512 760ce11686f921dd27bb9463c072d4ba6984efd59a0e93aca693cd3fd542376cefd41189c19b93f9ff33524e3faf6ecc36f3af673bcafe0166fe1936422a74e0
diff --git a/app-shells/loksh/loksh-7.5.ebuild b/app-shells/loksh/loksh-7.5.ebuild
index 587b3d778384..ae88ded1f660 100644
--- a/app-shells/loksh/loksh-7.5.ebuild
+++ b/app-shells/loksh/loksh-7.5.ebuild
@@ -6,14 +6,24 @@ EAPI=8
inherit meson
DESCRIPTION="Linux port of OpenBSD's ksh"
-HOMEPAGE="https://github.com/dimkr/loksh"
-SRC_URI="https://github.com/dimkr/loksh/releases/download/${PV}/${P}.tar.xz"
+HOMEPAGE="https://github.com/dimkr/loksh/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dimkr/${PN}.git"
+else
+ SRC_URI="https://github.com/dimkr/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+ KEYWORDS="~amd64 arm arm64 ~ppc64 ~riscv ~x86"
+fi
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-DEPEND="sys-libs/ncurses"
+DEPEND="
+ sys-libs/ncurses
+"
RDEPEND="
${DEPEND}
!app-shells/ksh
@@ -21,7 +31,8 @@ RDEPEND="
src_prepare() {
default
- sed -i "/install_dir/s@loksh@${PF}@" meson.build || die
+
+ sed -i "/install_dir/s@loksh@${PF}@" ./meson.build || die
}
src_configure() {
diff --git a/app-shells/loksh/loksh-7.6.ebuild b/app-shells/loksh/loksh-7.6.ebuild
new file mode 100644
index 000000000000..5a2d11d30b46
--- /dev/null
+++ b/app-shells/loksh/loksh-7.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dimkr/${PN}.git"
+else
+ SRC_URI="https://github.com/dimkr/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+
+DEPEND="
+ sys-libs/ncurses
+"
+RDEPEND="
+ ${DEPEND}
+ !app-shells/ksh
+"
+
+src_prepare() {
+ default
+
+ sed -i "/install_dir/s@loksh@${PF}@" ./meson.build || die
+}
+
+src_configure() {
+ # we want it as /bin/ksh
+ meson_src_configure --bindir=../bin
+}
diff --git a/app-shells/loksh/metadata.xml b/app-shells/loksh/metadata.xml
index ab65399f7988..c687a4dc6a84 100644
--- a/app-shells/loksh/metadata.xml
+++ b/app-shells/loksh/metadata.xml
@@ -1,8 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
<upstream>
+ <bugs-to>https://github.com/dimkr/loksh/issues/</bugs-to>
<remote-id type="github">dimkr/loksh</remote-id>
</upstream>
</pkgmetadata>