summaryrefslogtreecommitdiff
path: root/app-shells/peco/peco-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/peco/peco-9999.ebuild')
-rw-r--r--app-shells/peco/peco-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/peco/peco-9999.ebuild b/app-shells/peco/peco-9999.ebuild
new file mode 100644
index 000000000000..13314759377e
--- /dev/null
+++ b/app-shells/peco/peco-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_REPO_URI="https://github.com/peco/${PN}.git"
+
+inherit git-r3 go-module
+
+DESCRIPTION="Simplistic interactive filtering tool"
+HOMEPAGE="https://github.com/peco/peco"
+SRC_URI=""
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS=""
+
+DOCS=( {Changes,README.md} )
+
+src_unpack() {
+ git-r3_src_unpack
+ go-module_live_vendor
+}
+
+src_compile() {
+ ego build ./cmd/...
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ einstalldocs
+ dobin peco
+}