summaryrefslogtreecommitdiff
path: root/app-shells/push/push-3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/push/push-3.4.ebuild')
-rw-r--r--app-shells/push/push-3.4.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-shells/push/push-3.4.ebuild b/app-shells/push/push-3.4.ebuild
new file mode 100644
index 000000000000..e47ede3a3d18
--- /dev/null
+++ b/app-shells/push/push-3.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args"
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins bin/push.sh
+ dodoc README.md
+}