summaryrefslogtreecommitdiff
path: root/app-shells/pwsh/pwsh-7.3.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/pwsh/pwsh-7.3.9.ebuild')
-rw-r--r--app-shells/pwsh/pwsh-7.3.9.ebuild24
1 files changed, 23 insertions, 1 deletions
diff --git a/app-shells/pwsh/pwsh-7.3.9.ebuild b/app-shells/pwsh/pwsh-7.3.9.ebuild
index ca71f9702880..b4c0acc62c02 100644
--- a/app-shells/pwsh/pwsh-7.3.9.ebuild
+++ b/app-shells/pwsh/pwsh-7.3.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# NOTICE: Before packaging we have to run "ResGen" and "GetDependencies".
@@ -332,6 +332,28 @@ DOCS=( CHANGELOG CHANGELOG.md CODE_OF_CONDUCT.md README.md docs )
pkg_setup() {
check-reqs_pkg_setup
dotnet-pkg_pkg_setup
+
+ if [[ "${MERGE_TYPE}" != binary ]] ; then
+ if use elibc_glibc ; then
+ local locales="$(locale -a)"
+
+ if has en_US.utf8 ${locales} ; then
+ LC_ALL=en_US.utf8
+ elif has en_US.UTF-8 ${locales} ; then
+ LC_ALL=en_US.UTF-8
+ else
+ eerror "The locale en_US.utf8 or en_US.UTF-8 is not available."
+ eerror "Please generate en_US.UTF-8 before building ${CATEGORY}/${P}."
+
+ die "Could not switch to the en_US.UTF-8 locale."
+ fi
+ else
+ LC_ALL=en_US.UTF-8
+ fi
+
+ export LC_ALL
+ einfo "Successfully switched to the ${LC_ALL} locale."
+ fi
}
src_unpack() {